summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 22:49:38 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:33:19 +0000
commit857db69b3f6689997aac4687f84f1d476db74d6b (patch)
treec740b2334bba334fc7b7772f5e981b859117261f /games-misc
parentmedia-plugins/swh-lv2: update EAPI 6 -> 8 (diff)
downloadgentoo-857db69b3f6689997aac4687f84f1d476db74d6b.tar.gz
gentoo-857db69b3f6689997aac4687f84f1d476db74d6b.tar.bz2
gentoo-857db69b3f6689997aac4687f84f1d476db74d6b.zip
games-misc/sdljoytest: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index 8519be5e1834..50d329f815ea 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="SDL app to test joysticks and game controllers"
HOMEPAGE="http://sdljoytest.sourceforge.net/"
SRC_URI="mirror://sourceforge/sdljoytest/SDLJoytest-GL-${PV}.tar.bz2"
+S="${WORKDIR}"/SDLJoytest-GL
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl[joystick,opengl,video]
virtual/opengl
media-libs/sdl-image"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/SDLJoytest-GL
-
-PATCHES=("${FILESDIR}"/${P}-no-common.patch)
+PATCHES=( "${FILESDIR}"/${P}-no-common.patch )
src_prepare() {
default
@@ -31,7 +30,7 @@ src_prepare() {
src_compile() {
emake \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
}