summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/tuxtype
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/tuxtype')
-rw-r--r--games-kids/tuxtype/Manifest1
-rw-r--r--games-kids/tuxtype/metadata.xml5
-rw-r--r--games-kids/tuxtype/tuxtype-1.8.1.ebuild47
3 files changed, 53 insertions, 0 deletions
diff --git a/games-kids/tuxtype/Manifest b/games-kids/tuxtype/Manifest
new file mode 100644
index 000000000000..df9bbd4dc977
--- /dev/null
+++ b/games-kids/tuxtype/Manifest
@@ -0,0 +1 @@
+DIST tuxtype_w_fonts-1.8.1.tar.gz 11528002 SHA256 2687b858679b4f0b4f42204211d162234568198544bd95a9b71ec96e788d1481 SHA512 2c360807295f8d9f3d18f36b64c49e39fac78d81570c7a554244a01ee76627c90579e580b609ea7994378f5bbff916142e293ad94306b7b38d132fdc1c53734f WHIRLPOOL 9af2c761b6c1758cd4b3f5b746f9173b65a40972838e657a497b38ca3ec1e967a6b05193a69018ce0e4d9efaf9b781ef544b5196b4bc1c658ce7fd714b9d41a9
diff --git a/games-kids/tuxtype/metadata.xml b/games-kids/tuxtype/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-kids/tuxtype/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-kids/tuxtype/tuxtype-1.8.1.ebuild b/games-kids/tuxtype/tuxtype-1.8.1.ebuild
new file mode 100644
index 000000000000..50045ea7c921
--- /dev/null
+++ b/games-kids/tuxtype/tuxtype-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Typing tutorial with lots of eye-candy"
+HOMEPAGE="http://alioth.debian.org/projects/tux4kids/"
+SRC_URI="http://alioth.debian.org/frs/download.php/3270/tuxtype_w_fonts-${PV}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="svg"
+
+DEPEND="media-libs/libsdl:0[video]
+ media-libs/sdl-pango
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ svg? ( gnome-base/librsvg )"
+
+S=${WORKDIR}/tuxtype_w_fonts-${PV}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(prefix)/share:'${GAMES_DATADIR}':g' \
+ -e 's:$(prefix)/doc/$(PACKAGE):/usr/share/doc/'${PF}':g' \
+ $(find -name Makefile.in) || die
+}
+
+src_configure() {
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ $(use_with svg rsvg)
+}
+
+src_install() {
+ default
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL,ABOUT-NLS}*
+ doicon ${PN}.ico
+ make_desktop_entry ${PN} TuxTyping /usr/share/pixmaps/${PN}.ico
+ keepdir "${GAMES_SYSCONFDIR}/${PN}" "${GAMES_STATEDIR}/${PN}/words"
+ prepgamesdirs
+}