summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-02 03:05:47 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-02 03:05:47 -0500
commit185c755be18e8949e0fa6a3c6c2ca8209afd619e (patch)
tree24148b98f62365b8bcba4b3cd045e04168bd84dd /games-fps/tribes2/tribes2-25034.ebuild
parentnet-dns/bind: Stable for HPPA PPC64 (bug #568982). (diff)
downloadgentoo-185c755be18e8949e0fa6a3c6c2ca8209afd619e.tar.gz
gentoo-185c755be18e8949e0fa6a3c6c2ca8209afd619e.tar.bz2
gentoo-185c755be18e8949e0fa6a3c6c2ca8209afd619e.zip
games-fps/tribes2: EAPI=5; tidy
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-fps/tribes2/tribes2-25034.ebuild')
-rw-r--r--games-fps/tribes2/tribes2-25034.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/games-fps/tribes2/tribes2-25034.ebuild b/games-fps/tribes2/tribes2-25034.ebuild
index aba5b65b0a1b..2bcad311f4f8 100644
--- a/games-fps/tribes2/tribes2-25034.ebuild
+++ b/games-fps/tribes2/tribes2-25034.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
inherit eutils unpacker cdrom games
-IUSE=""
DESCRIPTION="Tribes 2 - Team Combat on an Epic Scale"
HOMEPAGE="http://www.lokigames.com/products/tribes2/"
SRC_URI="http://www.libsdl.org/projects/${PN}/release/${P}-cdrom-x86.run
@@ -16,6 +16,7 @@ SLOT="0"
# time to try to figure it out but this definitely needs to stay -amd64 until
# someone does fix the patching.
KEYWORDS="-amd64 x86"
+IUSE=""
RESTRICT="mirror strip"
DEPEND="sys-libs/glibc
@@ -41,26 +42,26 @@ src_unpack() {
src_install() {
einfo "Copying files... this may take a while..."
exeinto "${dir}"
- doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic} || die "doexe failed"
+ doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic}
insinto "${dir}"
- doins "${CDROM_ROOT}"/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} "${Ddir}" || die "copy failed"
+ doins "${CDROM_ROOT}"/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} "${Ddir}"
# Video card profiles
# TODO: move this to src_unpack where it belongs.
- tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die "uncompressing profiles"
+ tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die
# Base (Music, Textures, Maps, etc.)
- doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu || die "copying data"
+ doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu
cd "${S}"
loki_patch --verify patch.dat
- loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' +
newicon "${CDROM_ROOT}"/icon.xpm tribes2.xpm
games_make_wrapper t2launch ./t2launch "${dir}" "${dir}"