summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-05 18:57:14 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-26 01:53:46 +0200
commitf4b4d72527dc60b9b141732d781bd36f0c751040 (patch)
tree5c0884c01d63ea46db46a42f3720eaf1696351c7 /games-engines
parentgames-misc/wtf: add 20230906 (diff)
downloadgentoo-f4b4d72527dc60b9b141732d781bd36f0c751040.tar.gz
gentoo-f4b4d72527dc60b9b141732d781bd36f0c751040.tar.bz2
gentoo-f4b4d72527dc60b9b141732d781bd36f0c751040.zip
games-engines/qtads: add 3.4.0
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37982 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/qtads/Manifest1
-rw-r--r--games-engines/qtads/qtads-3.4.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
index 0136951ebe1a..6f6e586eed16 100644
--- a/games-engines/qtads/Manifest
+++ b/games-engines/qtads/Manifest
@@ -1 +1,2 @@
DIST qtads-3.3.0-source.tar.xz 6085960 BLAKE2B 516d9c38c1bed36d88f60ef746f1f8b7a82db14505e640c0d3024995a74c9efb68e7783111007db6ca7a2b6adbf7e5b96b6b1e7db1c0cce6441436e1ca81381b SHA512 7e2a647fc4bb81e9784a0b05b3fdee3e6306767aebd32466f6451dc8b2e0f61e01a5657d0bfb8ba091bdd8365c9fed4fd2ab5cd2a27bf5403a5192d42472f7b2
+DIST qtads-3.4.0-source.tar.xz 6059316 BLAKE2B 0aa1bd755aed6fe60a712754d5496a464296f990f99bb7fd3cf93e20ce86881837352739f77a0fe9b630cb67fc78f91fbabf3896e8105e2b51ffa7a46be90ce6 SHA512 b4d40ec3f757803beeb7e22afa7b2ae6a612970c11615378ed145870d577e30b5734cd316c4739e4a3726917654e268034e6ecf1132ebbe1e120dc56aa9a2e3b
diff --git a/games-engines/qtads/qtads-3.4.0.ebuild b/games-engines/qtads/qtads-3.4.0.ebuild
new file mode 100644
index 000000000000..63e98570846a
--- /dev/null
+++ b/games-engines/qtads/qtads-3.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="https://realnc.github.io/qtads"
+SRC_URI="https://github.com/realnc/qtads/releases/download/v${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sound"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[jpeg,png]
+ dev-qt/qtimageformats:5[mng]
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ sound? (
+ media-libs/libsdl2[sound]
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-sound/fluidsynth:0=
+ media-sound/mpg123
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 \
+ PREFIX="${EPREFIX}/usr" \
+ DOCDIR="${EPREFIX}/usr/share/${PF}" \
+ $(usev !sound CONFIG+=disable-audio) \
+ -after CONFIG-=silent
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}