summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/openxcom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/openxcom')
-rw-r--r--games-engines/openxcom/Manifest1
-rw-r--r--games-engines/openxcom/metadata.xml8
-rw-r--r--games-engines/openxcom/openxcom-1.0.0.ebuild73
3 files changed, 82 insertions, 0 deletions
diff --git a/games-engines/openxcom/Manifest b/games-engines/openxcom/Manifest
new file mode 100644
index 000000000000..a2ca9a2c98e8
--- /dev/null
+++ b/games-engines/openxcom/Manifest
@@ -0,0 +1 @@
+DIST openxcom-1.0.0.tar.gz 2068640 SHA256 45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246 SHA512 597abd2e7160551a3d6020d7c6fec863f86b708910ee582d446f2a5f97be94dc7e2522ede2e7ab4f62a2d21acf07ce441a435f74b530950e2f0b5791c00e06ab WHIRLPOOL fe63cb513b5413e16656f711564ce21eac3d3dc7a7674dcb62bc01f022b49c23dead30e80bbc0545f58e5a8a35cd635fd721c6243900a0bdba86de14c8ab8de9
diff --git a/games-engines/openxcom/metadata.xml b/games-engines/openxcom/metadata.xml
new file mode 100644
index 000000000000..68f685986c3e
--- /dev/null
+++ b/games-engines/openxcom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="github">SupSuper/OpenXcom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/openxcom/openxcom-1.0.0.ebuild b/games-engines/openxcom/openxcom-1.0.0.ebuild
new file mode 100644
index 000000000000..e0c0c6be289c
--- /dev/null
+++ b/games-engines/openxcom/openxcom-1.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+HOMEPAGE="http://openxcom.org/"
+SRC_URI="https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[flac,mikmod,vorbis]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( README.txt )
+
+S=${WORKDIR}/OpenXcom-1.0
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATADIR=${GAMES_DATADIR}/${PN}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ use doc && cmake-utils_src_compile doxygen
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ doicon -s scalable res/linux/icons/openxcom.svg
+ newicon -s 48 res/linux/icons/openxcom_48x48.png openxcom.png
+ newicon -s 128 res/linux/icons/openxcom_128x128.png openxcom.png
+ domenu res/linux/openxcom.desktop
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ echo
+ elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
+ elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
+ elog "${GAMES_DATADIR}/${PN}/data"
+ echo
+ elog "If you need or want text in some language other than english, download:"
+ elog "http://openxcom.org/translations/latest.zip and uncompress it in"
+ elog "${GAMES_DATADIR}/${PN}/data/Language"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}