summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 22:39:29 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 23:58:06 -0500
commit5e4b089e913c1b6c5888b0b9e4e1bbcce36577b4 (patch)
tree71b9b7dce65cc67c0c8e0a3a17ca1377ea939fea /games-emulation/gngb/gngb-20060309-r2.ebuild
parentgames-emulation/desmume: fix w/ clang16, filter-lto + -fno-strict (diff)
downloadgentoo-5e4b089e913c1b6c5888b0b9e4e1bbcce36577b4.tar.gz
gentoo-5e4b089e913c1b6c5888b0b9e4e1bbcce36577b4.tar.bz2
gentoo-5e4b089e913c1b6c5888b0b9e4e1bbcce36577b4.zip
games-emulation/gngb: EAPI6->8, fix build w/ clang16, C2x, and lto
Also GPL-2 -> GPL-2+, and fixing clang16 issues also fixed lto ones wrt bug #858641 ... but the real fix here would last rites, this is a terrible GB emulator by modern standards. Closes: https://bugs.gentoo.org/858641 Closes: https://bugs.gentoo.org/874999 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/gngb/gngb-20060309-r2.ebuild')
-rw-r--r--games-emulation/gngb/gngb-20060309-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-emulation/gngb/gngb-20060309-r2.ebuild b/games-emulation/gngb/gngb-20060309-r2.ebuild
new file mode 100644
index 000000000000..6ce2b27a4cb1
--- /dev/null
+++ b/games-emulation/gngb/gngb-20060309-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngb/"
+SRC_URI="http://m.peponas.free.fr/gngb/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="opengl"
+
+RDEPEND="
+ app-arch/bzip2:=
+ media-libs/libsdl[sound,joystick,video]
+ sys-libs/zlib:=
+ opengl? ( media-libs/libglvnd[X] )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # From Debian
+ "${FILESDIR}"/${P}-amd64.patch
+ "${FILESDIR}"/${P}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+ "${FILESDIR}"/${P}-inline.patch
+ "${FILESDIR}"/${P}-joystick.patch
+ "${FILESDIR}"/${P}-qwerty.patch
+ # Ours
+ "${FILESDIR}"/${P}-gcc10.patch
+ "${FILESDIR}"/${P}-gentoo-zlib.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
+ econf $(use_enable opengl gl)
+}