summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-15 22:10:32 -0700
committerSam James <sam@gentoo.org>2023-04-16 07:45:33 +0100
commitbae6887641a6b1c828a2fba1088e14c1e98a6b3c (patch)
tree2f942725d143c45f0ff346309a9c85adc1c5adca /games-emulation/cega-jg
parentdev-ruby/rdoc: update upstream metadata (diff)
downloadgentoo-bae6887641a6b1c828a2fba1088e14c1e98a6b3c.tar.gz
gentoo-bae6887641a6b1c828a2fba1088e14c1e98a6b3c.tar.bz2
gentoo-bae6887641a6b1c828a2fba1088e14c1e98a6b3c.zip
games-emulation/cega-jg: add 0.6.0
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/30615 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/cega-jg')
-rw-r--r--games-emulation/cega-jg/Manifest1
-rw-r--r--games-emulation/cega-jg/cega-jg-0.6.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-emulation/cega-jg/Manifest b/games-emulation/cega-jg/Manifest
index 3027c80268d3..c334a2ee7250 100644
--- a/games-emulation/cega-jg/Manifest
+++ b/games-emulation/cega-jg/Manifest
@@ -1 +1,2 @@
DIST cega-0.5.2.tar.bz2 221146 BLAKE2B eba8dcee12ebc2c4f290b7c4546e110bd4d154e3a2d9572fe8a0141c435e45fcd270085882754bf46e0a26388c8b92c5ac390c52b0be3a56a08122acd98d052b SHA512 e2177079a984e531480572e3552d3e52cc14ee2f55ba5d7836becda1c893c9721a637c3e89e992a0fe4039471b41c718f92c53b74f7165690cbc2e709623d7cb
+DIST cega-0.6.0.tar.bz2 224108 BLAKE2B 0ecbdcc05c4d7de405e78723117a5c09f7d26a39355a25e516a68c6473ee403cab55d7d12e57e3382db6730a406d7b639153ebcb6a6b038bf661af0eb08cfa72 SHA512 64d05bdc9dbc123400a2bd718e2e6b65edb87eaed7ef7915ce5bc9b86ce5ed9a801ffb9192103ac08a58a9c06193d7588dbe47b78143edb90a89139cf75cdc68
diff --git a/games-emulation/cega-jg/cega-jg-0.6.0.ebuild b/games-emulation/cega-jg/cega-jg-0.6.0.ebuild
new file mode 100644
index 000000000000..d75a4059c58a
--- /dev/null
+++ b/games-emulation/cega-jg/cega-jg-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good SG-1000, SMS, and Game Gear Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/cega"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT MPL-2.0 ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}