summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/xmille
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/xmille')
-rw-r--r--games-board/xmille/Manifest2
-rw-r--r--games-board/xmille/metadata.xml5
-rw-r--r--games-board/xmille/xmille-2.0-r2.ebuild46
3 files changed, 53 insertions, 0 deletions
diff --git a/games-board/xmille/Manifest b/games-board/xmille/Manifest
new file mode 100644
index 000000000000..3a288fc85ec0
--- /dev/null
+++ b/games-board/xmille/Manifest
@@ -0,0 +1,2 @@
+DIST xmille_2.0-12.diff.gz 6041 SHA256 a5266f279a680d600b7c97a6d691d6e69eee03737349f64e29d1b21791ea242d SHA512 8f8a71ce6f4359b4d8fbecd0e6149783abc4ded07da485c91c67784fd6c4988d074ad9bda7a8a47689ffe379dd8d20f9968ef7e6998ed22b735c51a2fae5828d WHIRLPOOL e2bedc1a243cde9103a36996b42d4be6d188705583e75fa79a4ead54b0fd4e4ed4699dc998431423760bd3c5253edc202b55a097af935041516b5026c13464c0
+DIST xmille_2.0.orig.tar.gz 68178 SHA256 52a621f9adb55bbed06e72981ab8efdafecda2d301068513ec9a815d21456abb SHA512 028740785dfc13b4088810855358b9dab75fbb79221dd4218ef0c19550c2180fe92e553d0a474bf45091b4008988e1a093a6d5bac99fe1ccafcaec3429cd0e8b WHIRLPOOL 8204509fa66552634e35508093b0c18253afd93fd3d2c2e2401d370b03cedb5be02e19c8b7974cac4df087953716032b2a1d547ff07b52e8d968276abfcfe585
diff --git a/games-board/xmille/metadata.xml b/games-board/xmille/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/xmille/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/xmille/xmille-2.0-r2.ebuild b/games-board/xmille/xmille-2.0-r2.ebuild
new file mode 100644
index 000000000000..5cabd02d6e34
--- /dev/null
+++ b/games-board/xmille/xmille-2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DEB_PATCH_VER="12"
+DESCRIPTION="Mille Bournes card game"
+HOMEPAGE="http://www.milleborne.info/"
+SRC_URI="mirror://debian/pool/main/x/xmille/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xmille/${PN}_${PV}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=( "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff )
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake -j1 \
+ AR="$(tc-getAR) clq" \
+ RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin xmille
+ dodoc CHANGES README
+ newman xmille.man xmille.6
+ prepgamesdirs
+}