summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-02 06:25:46 +0000
committerSam James <sam@gentoo.org>2023-02-02 06:26:58 +0000
commit7791570ded5f2cfdd4cadd3f7121f65ae208ce09 (patch)
treeb0431dc6e184faa0eb5b8062df682e4467ae0e81 /games-board/gnuchess/gnuchess-6.2.9-r1.ebuild
parentdev-libs/rasqal: fix configure w/ clang 16 (diff)
downloadgentoo-7791570ded5f2cfdd4cadd3f7121f65ae208ce09.tar.gz
gentoo-7791570ded5f2cfdd4cadd3f7121f65ae208ce09.tar.bz2
gentoo-7791570ded5f2cfdd4cadd3f7121f65ae208ce09.zip
games-board/gnuchess: fix configure w/ Clang 16, fix C++17 compat
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board/gnuchess/gnuchess-6.2.9-r1.ebuild')
-rw-r--r--games-board/gnuchess/gnuchess-6.2.9-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-board/gnuchess/gnuchess-6.2.9-r1.ebuild b/games-board/gnuchess/gnuchess-6.2.9-r1.ebuild
new file mode 100644
index 000000000000..c49bebcca0bd
--- /dev/null
+++ b/games-board/gnuchess/gnuchess-6.2.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Console based chess interface"
+HOMEPAGE="https://www.gnu.org/software/chess/chess.html"
+SRC_URI="mirror://gnu/chess/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.2.9-c++17.patch
+ "${FILESDIR}"/${PN}-6.2.9-configure-quoting.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for clang 16 patch (quoting)
+ eautoreconf
+}
+
+src_configure() {
+ # -Wodr warnings, bug #858611
+ filter-lto
+
+ # bug #491088
+ econf --without-readline
+}