summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/gnome-mahjongg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/gnome-mahjongg')
-rw-r--r--games-board/gnome-mahjongg/Manifest2
-rw-r--r--games-board/gnome-mahjongg/gnome-mahjongg-3.14.1.ebuild34
-rw-r--r--games-board/gnome-mahjongg/gnome-mahjongg-3.16.1.ebuild35
-rw-r--r--games-board/gnome-mahjongg/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/games-board/gnome-mahjongg/Manifest b/games-board/gnome-mahjongg/Manifest
new file mode 100644
index 000000000000..4953b4943f8a
--- /dev/null
+++ b/games-board/gnome-mahjongg/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-mahjongg-3.14.1.tar.xz 4132396 SHA256 6adb231ce97dd650345e15824ecba7bb73edb8590e52446b8adbb4e2cd9ec75d SHA512 a3772e9614a9e2c25826f53f99a1a23eb20d78e70692e1f833e57b34fb8e150e476450b76edddbe64c072a72304c5bee3b8277f7a7b86c1670cc825c0eaf5d64 WHIRLPOOL 06fa9d9165a5e0c53fb33f5ab0d2d1c0ecd07771cddbb37bbc5e9c135659fecaf8f536e6447c2c87739032e5323d9885c58ffbef285e73d3a378bed0a6eedc9c
+DIST gnome-mahjongg-3.16.1.tar.xz 4119500 SHA256 f2c607875402649182bd819bedd8cd8496539aca2aea9eb432c3e15ed71b6dc9 SHA512 679d11dc6fae10e51c66b25ea6b5ce7c61a29812dd64183145859570966a46bbfb34e5579a12000027aeb1eeeb8c874b3b2539a0c29da6ea2bb1ac4150cb6acd WHIRLPOOL 420220aac0f42f5ea1a2069c84edd73a16fd3813e29d310b6738bbae783d83a6a9794f65369e297ffeef9b4d15c9709baddf65e09fb67db4a1a024b14d50200f
diff --git a/games-board/gnome-mahjongg/gnome-mahjongg-3.14.1.ebuild b/games-board/gnome-mahjongg/gnome-mahjongg-3.14.1.ebuild
new file mode 100644
index 000000000000..bd1dc750af07
--- /dev/null
+++ b/games-board/gnome-mahjongg/gnome-mahjongg-3.14.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome-games vala
+
+DESCRIPTION="Disassemble a pile of tiles by removing matching pairs"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mahjongg"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32
+ >=x11-libs/gtk+-3.13.2:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}
diff --git a/games-board/gnome-mahjongg/gnome-mahjongg-3.16.1.ebuild b/games-board/gnome-mahjongg/gnome-mahjongg-3.16.1.ebuild
new file mode 100644
index 000000000000..83764b827d69
--- /dev/null
+++ b/games-board/gnome-mahjongg/gnome-mahjongg-3.16.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome-games vala
+
+DESCRIPTION="Disassemble a pile of tiles by removing matching pairs"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mahjongg"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32
+ >=x11-libs/gtk+-3.13.2:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}
diff --git a/games-board/gnome-mahjongg/metadata.xml b/games-board/gnome-mahjongg/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/games-board/gnome-mahjongg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>