summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 13:00:59 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-08 13:24:27 -0500
commitfd856d6dfc5d758b64d174fb04fb15afbfe84c7a (patch)
tree334b366a4cf496a2ba65f6befa450299ced27123 /games-board/atakks
parentgames-board/ace: remove deprecated games eclass (diff)
downloadgentoo-fd856d6dfc5d758b64d174fb04fb15afbfe84c7a.tar.gz
gentoo-fd856d6dfc5d758b64d174fb04fb15afbfe84c7a.tar.bz2
gentoo-fd856d6dfc5d758b64d174fb04fb15afbfe84c7a.zip
games-board/atakks: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/atakks')
-rw-r--r--games-board/atakks/atakks-1.0-r1.ebuild49
-rw-r--r--games-board/atakks/files/1.0-warnings.patch4
-rw-r--r--games-board/atakks/files/atakks-1.0-as-needed.patch4
3 files changed, 53 insertions, 4 deletions
diff --git a/games-board/atakks/atakks-1.0-r1.ebuild b/games-board/atakks/atakks-1.0-r1.ebuild
new file mode 100644
index 000000000000..43a9d8880d9f
--- /dev/null
+++ b/games-board/atakks/atakks-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="A clone of Ataxx"
+HOMEPAGE="http://team.gcu-squad.org/~fab"
+# no version upstream
+#SRC_URI="http://team.gcu-squad.org/~fab/down/${PN}.tgz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-warnings.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_prepare() {
+ default
+
+ # Modify game data paths
+ sed -i \
+ -e "s:SDL_LoadBMP(\":SDL_LoadBMP(\"/usr/share/${PN}/:" \
+ main.c || die
+}
+
+src_compile() {
+ emake E_CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins *bmp
+ newicon icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Atakks /usr/share/pixmaps/${PN}.bmp
+}
diff --git a/games-board/atakks/files/1.0-warnings.patch b/games-board/atakks/files/1.0-warnings.patch
index a27e014d9603..7123bb4f7dd2 100644
--- a/games-board/atakks/files/1.0-warnings.patch
+++ b/games-board/atakks/files/1.0-warnings.patch
@@ -1,5 +1,5 @@
---- main.c.orig 2004-06-02 01:26:00.000000000 -0700
-+++ main.c 2004-06-02 01:27:30.000000000 -0700
+--- a/main.c 2004-06-02 01:26:00.000000000 -0700
++++ b/main.c 2004-06-02 01:27:30.000000000 -0700
@@ -13,6 +13,7 @@
#include<SDL/SDL.h>
#include<unistd.h>
diff --git a/games-board/atakks/files/atakks-1.0-as-needed.patch b/games-board/atakks/files/atakks-1.0-as-needed.patch
index b02e32002fa9..e496f5ff0d30 100644
--- a/games-board/atakks/files/atakks-1.0-as-needed.patch
+++ b/games-board/atakks/files/atakks-1.0-as-needed.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2009-02-03 10:02:08.000000000 +0100
-+++ Makefile 2009-02-03 10:04:12.000000000 +0100
+--- a/Makefile 2009-02-03 10:02:08.000000000 +0100
++++ b/Makefile 2009-02-03 10:04:12.000000000 +0100
@@ -1,10 +1,10 @@
-LDFLAGS= -lSDL -lpthread -s
-CFLAGS= -Wall -ansi # -DDEBUG