summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-22 20:02:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-22 23:16:03 +0200
commita2047e6fcbe5faa9972f9c1775e39aba965412f7 (patch)
treec2d49caee24158f2a0d2f9afd336288adb6cae5e /games-arcade
parentdev-libs/elfutils: stable 0.180 for hppa, bug #732862 (diff)
downloadgentoo-a2047e6fcbe5faa9972f9c1775e39aba965412f7.tar.gz
gentoo-a2047e6fcbe5faa9972f9c1775e39aba965412f7.tar.bz2
gentoo-a2047e6fcbe5faa9972f9c1775e39aba965412f7.zip
games-arcade/blobby: EAPI-7 bump, switch to cmake, fix dependencies
Package depends on media-libs/libsdl2, not media-libs/libsdl. Dropping media-libs/libsdl2[X] USE-dep on request of games proj. Closes: https://bugs.gentoo.org/606780 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blobby/blobby-1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/blobby/blobby-1.0-r1.ebuild b/games-arcade/blobby/blobby-1.0-r1.ebuild
new file mode 100644
index 000000000000..0044ddcffb2d
--- /dev/null
+++ b/games-arcade/blobby/blobby-1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop
+
+DESCRIPTION="Beach ball game with blobs of goo"
+HOMEPAGE="https://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-games/physfs-2[zip]
+ media-libs/libsdl2[sound,joystick,opengl,video]
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ app-arch/zip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-install.patch
+)
+
+src_install() {
+ cmake_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+}