summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xrick
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xrick')
-rw-r--r--games-arcade/xrick/Manifest1
-rw-r--r--games-arcade/xrick/files/xrick-021212-exit.patch23
-rw-r--r--games-arcade/xrick/files/xrick-021212-fullscreen.patch21
-rw-r--r--games-arcade/xrick/files/xrick-021212-zlib.patch13
-rw-r--r--games-arcade/xrick/metadata.xml5
-rw-r--r--games-arcade/xrick/xrick-021212-r1.ebuild55
6 files changed, 118 insertions, 0 deletions
diff --git a/games-arcade/xrick/Manifest b/games-arcade/xrick/Manifest
new file mode 100644
index 000000000000..c96d8ddf0bcf
--- /dev/null
+++ b/games-arcade/xrick/Manifest
@@ -0,0 +1 @@
+DIST xrick-021212.tgz 1648538 SHA256 aa8542120bec97a730258027a294bd16196eb8b3d66134483d085f698588fc2b SHA512 7a6547dfce586512c3c4aa7fd5aa0d7d8bd223dbec6a9211e858034bd73d44f168266441d8f3475cddbed8f3a19c7c0df31345b62e2ecfb860664e54facb48bf WHIRLPOOL 4706601639a622b75df0b1f6e6f93f39a00d0ba522487af7f0012833a27b3ba48cb9b0b5d660d4aaafae0931612b251c1529be7c687fa50b2aaf02603d11d7e9
diff --git a/games-arcade/xrick/files/xrick-021212-exit.patch b/games-arcade/xrick/files/xrick-021212-exit.patch
new file mode 100644
index 000000000000..4486a969b346
--- /dev/null
+++ b/games-arcade/xrick/files/xrick-021212-exit.patch
@@ -0,0 +1,23 @@
+diff -ur xrick-021212/src/sysjoy.c xrick-021212.patched/src/sysjoy.c
+--- xrick-021212/src/sysjoy.c 2010-10-23 00:33:33.000000000 +0400
++++ xrick-021212.patched/src/sysjoy.c 2010-10-23 00:42:25.000000000 +0400
+@@ -56,6 +56,7 @@
+ {
+ if (j)
+ SDL_JoystickClose(j);
++ j = NULL;
+ }
+
+ #endif /* ENABLE_JOYSTICK */
+diff -ur xrick-021212/src/xrick.c xrick-021212.patched/src/xrick.c
+--- xrick-021212/src/xrick.c 2010-10-23 00:33:33.000000000 +0400
++++ xrick-021212.patched/src/xrick.c 2010-10-23 00:40:47.000000000 +0400
+@@ -29,7 +29,7 @@
+ data_setpath("/usr/games/lib/xrick/data.zip");
+ game_run();
+ data_closepath();
+- sys_shutdown();
++ /* sys_shutdown is called via atexit */
+ return 0;
+ }
+
diff --git a/games-arcade/xrick/files/xrick-021212-fullscreen.patch b/games-arcade/xrick/files/xrick-021212-fullscreen.patch
new file mode 100644
index 000000000000..97271a33a28e
--- /dev/null
+++ b/games-arcade/xrick/files/xrick-021212-fullscreen.patch
@@ -0,0 +1,21 @@
+diff -ur xrick-021212/src/sysvid.c xrick-021212.patched/src/sysvid.c
+--- xrick-021212/src/sysvid.c 2002-12-24 16:33:43.000000000 +0300
++++ xrick-021212.patched/src/sysvid.c 2011-01-14 03:03:16.636668016 +0300
+@@ -145,10 +145,14 @@
+ IFDEBUG_VIDEO(sys_printf("xrick/video: SDL says, use these modes:\n"););
+ for (i = 0; modes[i]; i++) {
+ IFDEBUG_VIDEO(sys_printf(" %dx%d\n", modes[i]->w, modes[i]->h););
+- if (modes[i]->w <= modes[mode]->w && modes[i]->w >= SYSVID_WIDTH &&
+- modes[i]->h * SYSVID_WIDTH >= modes[i]->w * SYSVID_HEIGHT) {
++ if ((!fszoom && modes[i]->w <= modes[mode] &&
++ modes[i]->w >= SYSVID_WIDTH) ||
++ (fszoom && modes[i]->w > modes[mode]->w)) {
+ mode = i;
+- fszoom = modes[mode]->w / SYSVID_WIDTH;
++ if (modes[i]->h * SYSVID_WIDTH >= modes[i]->w * SYSVID_HEIGHT)
++ fszoom = modes[mode]->w / SYSVID_WIDTH;
++ else
++ fszoom = modes[mode]->h / SYSVID_HEIGHT;
+ }
+ }
+ if (fszoom != 0) {
diff --git a/games-arcade/xrick/files/xrick-021212-zlib.patch b/games-arcade/xrick/files/xrick-021212-zlib.patch
new file mode 100644
index 000000000000..da09a46369d6
--- /dev/null
+++ b/games-arcade/xrick/files/xrick-021212-zlib.patch
@@ -0,0 +1,13 @@
+--- include/unzip.h.old 2012-03-24 16:13:16.012854948 +0100
++++ include/unzip.h 2012-03-24 16:15:42.744346771 +0100
+@@ -49,6 +49,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifdef _Z_OF
++#define OF _Z_OF
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */
diff --git a/games-arcade/xrick/metadata.xml b/games-arcade/xrick/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xrick/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xrick/xrick-021212-r1.ebuild b/games-arcade/xrick/xrick-021212-r1.ebuild
new file mode 100644
index 000000000000..4522774011b9
--- /dev/null
+++ b/games-arcade/xrick/xrick-021212-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Clone of the Rick Dangerous adventure game from the 80's"
+HOMEPAGE="http://www.bigorno.net/xrick/"
+SRC_URI="http://www.bigorno.net/xrick/${P}.tgz"
+
+LICENSE="GPL-1+ xrick"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="mirror bindist" # bug #149097
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./xrick.6.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}*.patch
+ sed -i \
+ -e "/^run from/d" \
+ -e "/data.zip/ s:the directory where xrick is:$(games_get_libdir)/${PN}.:" \
+ xrick.6 || die
+
+ sed -i \
+ -e "s:data.zip:$(games_get_libdir)/${PN}/data.zip:" \
+ src/xrick.c || die
+
+ sed -i \
+ -e "s/-g -ansi -pedantic -Wall -W -O2/${CFLAGS}/" \
+ -e '/LDFLAGS/s/=/+=/' \
+ -e '/CC=/d' \
+ -e "/CPP=/ { s/gcc/\$(CC)/; s/\"/'/g }" \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin xrick
+ insinto "$(games_get_libdir)"/${PN}
+ doins data.zip
+ newicon src/xrickST.ico ${PN}.ico
+ make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
+ dodoc README KeyCodes
+ doman xrick.6
+ prepgamesdirs
+}