summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/fishsupper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/fishsupper')
-rw-r--r--games-arcade/fishsupper/Manifest1
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch11
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch11
-rw-r--r--games-arcade/fishsupper/fishsupper-0.1.6.ebuild36
-rw-r--r--games-arcade/fishsupper/metadata.xml8
5 files changed, 67 insertions, 0 deletions
diff --git a/games-arcade/fishsupper/Manifest b/games-arcade/fishsupper/Manifest
new file mode 100644
index 000000000000..ede8fd89bcd3
--- /dev/null
+++ b/games-arcade/fishsupper/Manifest
@@ -0,0 +1 @@
+DIST fishsupper-0.1.6.tar.gz 1136893 SHA256 d2d026ce9567fd6a86cb1c81458b540fd511d269d1af37c9e29df145091da3a8 SHA512 a6b3df47010e8ac186ff4446db3659fd9173e9e3fc973ab376eed46da9cd13f7a4c0c02b25f3427232252e7fe5728036fa91ea773affe0948387a56f617fc7af WHIRLPOOL 5bc48a1cbd0a41b45cb905de9e6592ea3fd52cb5426bcc0c224cb6f0bbcb3489454e06154f614d2df5db4af0c12b526acf7c05ee7361407f97fa463448ea1095
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch
new file mode 100644
index 000000000000..2aba6f099e88
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.old 2012-06-24 18:47:58.947143638 +0200
++++ src/Makefile.am 2012-06-24 18:51:35.738921904 +0200
+@@ -1,7 +1,7 @@
+ AM_CPPFLAGS = -DPKG_DATA_DIR=\"$(pkgdatadir)\" \
+ @SDL_CFLAGS@ \
+ -Wall
+-AM_LDFLAGS = @SDL_LIBS@
++LDADD = @SDL_LIBS@
+
+ bin_PROGRAMS = fishsupper
+
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch
new file mode 100644
index 000000000000..4d5185dae7e9
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch
@@ -0,0 +1,11 @@
+--- src/main.cpp.old 2012-06-24 18:35:27.661894094 +0200
++++ src/main.cpp 2012-06-24 18:35:41.041954632 +0200
+@@ -293,7 +293,7 @@
+
+ if (!ok)
+ {
+- fs_dir = new char[ strlen(".") ];
++ fs_dir = new char[ strlen(".") + 1];
+ strcpy(fs_dir, ".");
+ } // if ... else
+
diff --git a/games-arcade/fishsupper/fishsupper-0.1.6.ebuild b/games-arcade/fishsupper/fishsupper-0.1.6.ebuild
new file mode 100644
index 000000000000..667fd00a28f9
--- /dev/null
+++ b/games-arcade/fishsupper/fishsupper-0.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="A simple arcade/puzzle game, loosely based on the retro classic Frogger"
+HOMEPAGE="http://sourceforge.net/projects/fishsupper/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-2.5 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video,opengl,X]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[wav]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon data/images/fs_sprite_042.png ${PN}.png
+ make_desktop_entry ${PN} "Fish Supper"
+
+ prepgamesdirs
+}
diff --git a/games-arcade/fishsupper/metadata.xml b/games-arcade/fishsupper/metadata.xml
new file mode 100644
index 000000000000..6f7bdf45da78
--- /dev/null
+++ b/games-arcade/fishsupper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">fishsupper</remote-id>
+ </upstream>
+</pkgmetadata>