summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-12 02:38:19 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-12 03:03:47 -0500
commit178ac9cf1bd0d178d65c3268f35c5b6a1e048f6d (patch)
treecffea76a934e15625eb94e65dbb9d3e9cab9f4cd /games-arcade/cdogs-sdl
parentapp-portage/iwdevtools: stabilize 0.12.3 for ALLARCHES (diff)
downloadgentoo-178ac9cf1bd0d178d65c3268f35c5b6a1e048f6d.tar.gz
gentoo-178ac9cf1bd0d178d65c3268f35c5b6a1e048f6d.tar.bz2
gentoo-178ac9cf1bd0d178d65c3268f35c5b6a1e048f6d.zip
games-arcade/cdogs-sdl: add 1.4.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/cdogs-sdl')
-rw-r--r--games-arcade/cdogs-sdl/Manifest1
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-1.4.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/Manifest b/games-arcade/cdogs-sdl/Manifest
index db1e78590cf0..b5293ba7fd2d 100644
--- a/games-arcade/cdogs-sdl/Manifest
+++ b/games-arcade/cdogs-sdl/Manifest
@@ -1 +1,2 @@
DIST cdogs-sdl-1.4.0.tar.gz 35203975 BLAKE2B 4966b6beacd8b0b83f6a59865a6347bea2ecabbc508317dd41bab286a25d06fe26de0e9cee0591f31c259a56c666734609ea4ce7710d820fcf446b280d6db42f SHA512 31a2802248cb4a16331181fa7c0cbc5b1cd5f85244554f5eccfeb1003a813452d08c6249521b7e9e800e48d636b0e7f8f8d592e54706bfcdf3dab88105ee0f28
+DIST cdogs-sdl-1.4.1.tar.gz 35799934 BLAKE2B 67fe75575c478a3e38a7ba70060dc329c98b1b96912216dbf4a7d71784222485efff645349c2d9db72184947f16dcbd73ba52e61a03ad9b4c341650ab9ce144c SHA512 de8d181fed78d68ebeed44b408210252c616db7aaf80d472ea2ce3981fca8792c0226bb0006af014bc9151e2c1ba1b94708441e4c039ba2648cef3e41b31feda
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-1.4.1.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-1.4.1.ebuild
new file mode 100644
index 000000000000..694b57d0eb85
--- /dev/null
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Classic overhead run-and-gun game"
+HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
+SRC_URI="https://github.com/cxong/cdogs-sdl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD-2 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0 CC0-1.0 WTFPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl2[haptic,opengl]
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[mp3,vorbis,wav]
+ net-libs/enet:1.3="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-cmake.patch
+)
+
+src_configure() {
+ # LTO warnings, bug #858527
+ filter-lto
+
+ local mycmakeargs=(
+ -DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/
+ -DBUILD_EDITOR=OFF
+ -DUSE_SHARED_ENET=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc doc/{AUTHORS,original_readme.txt}
+
+ # CREDITS is used at runtime, rest is licenses or duplicates
+ find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
+}