summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-06 04:47:15 +0000
committerSam James <sam@gentoo.org>2024-02-06 04:56:14 +0000
commitdd9f5a0b35a3d402eb2f24d1146029baba0b0604 (patch)
treebfc24358c2d252291404c6d8737c6046140f3c2d /dev-vcs
parentapp-portage/elt-patches: drop 20231228, 20240109 (diff)
downloadgentoo-dd9f5a0b35a3d402eb2f24d1146029baba0b0604.tar.gz
gentoo-dd9f5a0b35a3d402eb2f24d1146029baba0b0604.tar.bz2
gentoo-dd9f5a0b35a3d402eb2f24d1146029baba0b0604.zip
dev-vcs/subversion: add 1.14.3
* Inline patches from tarball in SRC_URI (404'd). We were already deleting some patches from it and there was a lot of fuzz in another (obsolete patch for interix). * EAPI 8 * Add support for ruby32 (comes with this release). * Drop old libutf8proc hack & depend on newer version so we can drop that hack. * Run tests in parallel which helps a fair bit. * Run tests with -Onone so it doesn't look like they're hanging. * Add misc. missing || dies. Closes: https://bugs.gentoo.org/919090 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/Manifest1
-rw-r--r--dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch28
-rw-r--r--dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch21
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch85
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch19
-rw-r--r--dev-vcs/subversion/subversion-1.14.3.ebuild445
6 files changed, 599 insertions, 0 deletions
diff --git a/dev-vcs/subversion/Manifest b/dev-vcs/subversion/Manifest
index 0b4b2863e158..552c86fa6c00 100644
--- a/dev-vcs/subversion/Manifest
+++ b/dev-vcs/subversion/Manifest
@@ -1,2 +1,3 @@
DIST subversion-1.10.0_rc1-patches-1.tar.xz 2984 BLAKE2B 7c9619b95ca6b433a58dc5baf3a1e1b14ef0017f714af81762b975d50a37b743788a4da65cf7f9eb8e633cbc813ad8dd974b530a19ec2d3fc74b75921f8f0c17 SHA512 aa7a25a253ea2da99520399d292d3e1602985392bae6dc5582003fdb9719d654638754b6e370b68b184ee6729ba3833bd511c09b2cb36f8f476b42063f55fbb2
DIST subversion-1.14.2.tar.bz2 8606570 BLAKE2B cf15c61b932823fb18b52f83d84907386f068d2d40e14dbab94c42ad9d4c0fdf35d82db78036d7c1f2be47c2d51cdd27bfb966eb7607a52a21e072aeff76fb38 SHA512 20ada4688ca07d9fb8da4b7d53b5084568652a3b9418c65e688886bae950a16a3ff37710fcfc9c29ef14a89e75b2ceec4e9cf35d5876a7896ebc2b512cfb9ecc
+DIST subversion-1.14.3.tar.bz2 8569985 BLAKE2B bc366a611f77d7dc3a5dc6015ea50b8daae0cffc20f8830de04a7f310a26ab9e955db343e7902475079d31d7984cb6b03f7810e71feae9a5374e1cb690933b49 SHA512 40b172492005fd3b0cd9e457b4444af8ea5d8ff8fc161a9a0c6dc3a7314c6ad4ff75a4676f68a1919ae6273ae03e34d04eba8c1c37b8c0b4ec70d6731b527b41
diff --git a/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch b/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch
new file mode 100644
index 000000000000..161984f978f9
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/919090
+https://src.fedoraproject.org/rpms/subversion/blob/rawhide/f/subversion-ruby-c99.patch
+
+The Ruby bindings apply the Ruby NIL_P macro to an apr_hash_t * value,
+which some compilers flag as a type error.
+
+Submitted upstream: <https://issues.apache.org/jira/browse/SVN-4915>
+
+--- a/subversion/bindings/swig/include/svn_containers.swg
++++ b/subversion/bindings/swig/include/svn_containers.swg
+@@ -299,7 +299,7 @@
+ $1 = svn_swig_rb_hash_to_apr_hash_svn_string($input, _global_pool);
+ _global_pool = NULL;
+ if (!NIL_P(rb_pool)) {
+- if (NIL_P($1)) {
++ if ($1 == NULL) {
+ svn_swig_rb_destroy_pool(rb_pool);
+ } else {
+ svn_swig_rb_set_pool_for_no_swig_type($input, rb_pool);
+@@ -373,7 +373,7 @@
+ svn_swig_rb_hash_to_apr_hash_string($input, _global_pool);
+ _global_pool = NULL;
+ if (!NIL_P(rb_pool)) {
+- if (NIL_P($1)) {
++ if ($1 == NULL) {
+ svn_swig_rb_destroy_pool(rb_pool);
+ } else {
+ svn_swig_rb_set_pool_for_no_swig_type($input, rb_pool);
diff --git a/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch b/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch
new file mode 100644
index 000000000000..69a4355f17af
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch
@@ -0,0 +1,21 @@
+On AIX, load shared libraries even when created with full aix-soname support:
+http://lists.gnu.org/archive/html/libtool/2011-01/msg00023.html
+http://lists.gnu.org/archive/html/libtool/2011-02/msg00000.html
+Once there is an agreement on that, this patch eventually is for upstream too.
+
+--- a/subversion/libsvn_ra/ra_loader.c
++++ b/subversion/libsvn_ra/ra_loader.c
+@@ -164,6 +164,13 @@
+
+ /* find/load the specified library */
+ SVN_ERR(svn_dso_load(&dso, libname));
++#ifdef _AIX
++ if (! dso) {
++ libname = apr_psprintf(pool, "libsvn_ra_%s-%d.so.0(shr.o)",
++ ra_name, SVN_VER_MAJOR);
++ SVN_ERR(svn_dso_load(&dso, libname));
++ }
++#endif
+ if (! dso)
+ return SVN_NO_ERROR;
+
diff --git a/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
new file mode 100644
index 000000000000..158c08233165
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
@@ -0,0 +1,85 @@
+--- subversion-1.8.1/build/ac-macros/berkeley-db.m4
++++ subversion-1.8.1/build/ac-macros/berkeley-db.m4
+@@ -48,7 +48,7 @@
+ AC_ARG_WITH(berkeley-db, [AS_HELP_STRING(
+ [[--with-berkeley-db[=HEADER:INCLUDES:LIB_SEARCH_DIRS:LIBS]]], [
+ The Subversion Berkeley DB based filesystem library
+- requires Berkeley DB $db_version or $db_alt_version. If you
++ requires Berkeley DB $db_version or newer. If you
+ specify `--without-berkeley-db', that library will
+ not be built. If you omit the argument of this option
+ completely, the configure script will use Berkeley DB
+@@ -126,35 +126,22 @@
+ svn_lib_berkeley_db=no
+ else
+ AC_MSG_CHECKING([for availability of Berkeley DB])
+- AC_ARG_ENABLE(bdb6,
+- AS_HELP_STRING([--enable-bdb6],
+- [Allow building against BDB 6+.
+- See --with-berkeley-db for specifying the location of
+- the Berkeley DB installation. Using BDB 6 will fail if
+- this option is not used.]),
+- [enable_bdb6=$enableval],[enable_bdb6=unspecified])
+-
+- SVN_LIB_BERKELEY_DB_TRY($1, $2, $3, $enable_bdb6)
++ SVN_LIB_BERKELEY_DB_TRY($1, $2, $3)
+ if test "$svn_have_berkeley_db" = "yes"; then
+ AC_MSG_RESULT([yes])
+ svn_lib_berkeley_db=yes
+ else
+- if test "$svn_have_berkeley_db" = "no6"; then
+- AC_MSG_RESULT([no (found version 6, but --enable-bdb6 not specified)])
+- # A warning will be printed at the end of configure.ac.
+- else
+- AC_MSG_RESULT([no])
+- fi
++ AC_MSG_RESULT([no])
+ svn_lib_berkeley_db=no
+ if test "$bdb_status" = "required"; then
+- AC_MSG_ERROR([Berkeley DB $db_version or $db_alt_version wasn't found.])
++ AC_MSG_ERROR([Berkeley DB $db_version or newer't found.])
+ fi
+ fi
+ fi
+ ])
+
+
+-dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch, enable_bdb6)
++dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch)
+ dnl
+ dnl A subroutine of SVN_LIB_BERKELEY_DB.
+ dnl
+@@ -187,7 +174,6 @@
+ svn_check_berkeley_db_major=$1
+ svn_check_berkeley_db_minor=$2
+ svn_check_berkeley_db_patch=$3
+- enable_bdb6=$4
+
+ if test -z "$SVN_DB_LIBS"; then
+ # We pass --dbm-libs here since Debian has modified apu-config not
+@@ -245,12 +231,6 @@
+ || patch != DB_VERSION_PATCH)
+ exit (1);
+
+- /* Block Berkeley DB 6, because (a) we haven't tested with it, (b) 6.0.20
+- and newer are under the AGPL, and we want use of AGPL dependencies to be
+- opt-in. */
+- if (major >= 6 && strcmp("$enable_bdb6", "yes"))
+- exit(2);
+-
+ /* Run-time check: ensure the library claims to be the correct version. */
+
+ if (major < $svn_check_berkeley_db_major)
+@@ -270,11 +250,7 @@
+ }
+ ]])],
+ [svn_have_berkeley_db=yes],
+- [rc=$?
+- svn_have_berkeley_db=no
+- if test $rc = 2; then
+- svn_have_berkeley_db=no6
+- fi],
++ [svn_have_berkeley_db=no],
+ [svn_have_berkeley_db=yes]
+ )
+
diff --git a/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch b/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch
new file mode 100644
index 000000000000..8b07d22ca3f4
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch
@@ -0,0 +1,19 @@
+With newer versions of javadoc (since JDK-1.8), "make doc-javahl"
+reports many errors, causing build failures. Add "-Xdoclint:none"
+option to restore old, sloppy behavior.
+
+Patch created for subversion-1.8.16, should work for other other
+versions, too.
+See <https://bugs.gentoo.org/show_bug.cgi?id=551094>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -650,7 +650,7 @@
+
+ # Generate API documentation for the JavaHL package.
+ doc-javahl:
+- $(JAVADOC) -d $(abs_builddir)/doc/javadoc \
++ $(JAVADOC) -Xdoclint:none -d $(abs_builddir)/doc/javadoc \
+ -sourcepath $(top_srcdir)/subversion/bindings/javahl/src \
+ -link http://java.sun.com/javase/6/docs/api/ \
+ org.tigris.subversion.javahl \
diff --git a/dev-vcs/subversion/subversion-1.14.3.ebuild b/dev-vcs/subversion/subversion-1.14.3.ebuild
new file mode 100644
index 000000000000..fa840de5908c
--- /dev/null
+++ b/dev-vcs/subversion/subversion-1.14.3.ebuild
@@ -0,0 +1,445 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WANT_AUTOMAKE="none"
+GENTOO_DEPEND_ON_PERL="no"
+# no py3.12 yet as many tests have invalid escape sequence warnings
+PYTHON_COMPAT=( python3_{10..11} )
+USE_RUBY="ruby31 ruby32"
+
+inherit autotools bash-completion-r1 db-use depend.apache flag-o-matic java-pkg-opt-2
+inherit libtool multilib multiprocessing perl-module prefix python-any-r1 ruby-single xdg-utils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Advanced version control system"
+HOMEPAGE="https://subversion.apache.org/"
+SRC_URI="mirror://apache/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0 BSD MIT BSD-2 FSFAP unicode"
+SLOT="0"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+IUSE="apache2 berkdb debug doc extras keyring java kwallet nls perl plaintext-password-storage ruby sasl test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ app-arch/lz4
+ >=dev-db/sqlite-3.7.12
+ >=dev-libs/apr-1.5:1
+ >=dev-libs/apr-util-1.5:1
+ dev-libs/expat
+ >=dev-libs/libutf8proc-2.5.0:=
+ >=net-libs/serf-1.3.4
+ sys-apps/file
+ sys-libs/zlib
+ berkdb? ( >=sys-libs/db-4.0.14:= )
+ keyring? (
+ dev-libs/glib:2
+ app-crypt/libsecret
+ sys-apps/dbus
+ )
+ kwallet? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kwallet:5
+ sys-apps/dbus
+ )
+ perl? ( dev-lang/perl:= )
+ ruby? ( ${RUBY_DEPS} )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ apache2? (
+ acct-group/apache
+ acct-user/apache
+ www-servers/apache[apache2_modules_dav]
+ )
+ !apache2? (
+ acct-group/svnusers
+ acct-user/svn
+ )
+ java? ( >=virtual/jre-1.8:* )
+ nls? ( virtual/libintl )
+ perl? ( dev-perl/URI )
+"
+# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
+DEPEND="
+ ${COMMON_DEPEND}
+ java? ( >=virtual/jdk-1.8:* )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ test? ( ${PYTHON_DEPS} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.6-aix-dso.patch
+ "${FILESDIR}"/${PN}-1.8.1-revert_bdb6check.patch
+ "${FILESDIR}"/${PN}-1.8.16-javadoc-nolint.patch
+ "${FILESDIR}"/${PN}-1.14.3-ruby-c99.patch
+)
+
+want_apache
+
+pkg_setup() {
+ if use berkdb ; then
+ local apu_bdb_version="$("${EPREFIX}"/usr/bin/apu-1-config --includes \
+ | grep -Eoe '-I${EPREFIX}/usr/include/db[[:digit:]]\.[[:digit:]]' \
+ | sed 's:.*b::')"
+ einfo
+ if [[ -z "${SVN_BDB_VERSION}" ]] ; then
+ if [[ -n "${apu_bdb_version}" ]] ; then
+ SVN_BDB_VERSION="${apu_bdb_version}"
+ einfo "Matching db version to apr-util"
+ else
+ SVN_BDB_VERSION="$(db_ver_to_slot "$(db_findver sys-libs/db 2>/dev/null)")"
+ einfo "SVN_BDB_VERSION variable isn't set. You can set it to enforce using of specific version of Berkeley DB."
+ fi
+ fi
+ einfo "Using: Berkeley DB ${SVN_BDB_VERSION}"
+ einfo
+
+ if [[ -n "${apu_bdb_version}" && "${SVN_BDB_VERSION}" != "${apu_bdb_version}" ]]; then
+ eerror "APR-Util is linked against Berkeley DB ${apu_bdb_version}, but you are trying"
+ eerror "to build Subversion with support for Berkeley DB ${SVN_BDB_VERSION}."
+ eerror "Rebuild dev-libs/apr-util or set SVN_BDB_VERSION=\"${apu_bdb_version}\"."
+ eerror "Aborting to avoid possible run-time crashes."
+ die "Berkeley DB version mismatch"
+ fi
+ fi
+
+ depend.apache_pkg_setup
+
+ java-pkg-opt-2_pkg_setup
+
+ # https://issues.apache.org/jira/browse/SVN-4813#comment-16813739
+ append-cppflags -P
+
+ if use debug ; then
+ append-cppflags -DSVN_DEBUG -DAP_DEBUG
+ fi
+
+ # http://mail-archives.apache.org/mod_mbox/subversion-dev/201306.mbox/%3C51C42014.3060700@wandisco.com%3E
+ [[ ${CHOST} == *-solaris2* ]] && append-cppflags -D__EXTENSIONS__
+
+ # Allow for custom repository locations.
+ SVN_REPOS_LOC="${SVN_REPOS_LOC:-${EPREFIX}/var/svn}"
+
+ if use ruby ; then
+ local rbslot
+ RB_VER=""
+ for rbslot in $(sed 's@\([[:digit:]]\+\)\([[:digit:]]\)@\1.\2@g' <<< ${USE_RUBY//ruby}) ; do
+ # No break here as we want to pick the best (latest)
+ if has_version "dev-lang/ruby:${rbslot}" && has_version "virtual/rubygems[ruby_targets_ruby${rbslot/.}(-)]" ; then
+ RB_VER="${rbslot/.}"
+ fi
+ done
+ [[ -z "${RB_VER}" ]] && die "No usable ruby version found"
+ fi
+}
+
+src_prepare() {
+ default
+
+ chmod +x build/transform_libtool_scripts.sh || die
+
+ sed -i \
+ -e "s/\(BUILD_RULES=.*\) bdb-test\(.*\)/\1\2/g" \
+ -e "s/\(BUILD_RULES=.*\) test\(.*\)/\1\2/g" configure.ac
+
+ # this bites us in particular on Solaris
+ sed -i -e '1c\#!/usr/bin/env sh' build/transform_libtool_scripts.sh || \
+ die "/bin/sh is not POSIX shell!"
+
+ hprefixify build/ac-macros/svn-macros.m4
+
+ eautoconf
+ elibtoolize
+
+ sed -e 's/\(libsvn_swig_py\)-\(1\.la\)/\1-$(EPYTHON)-\2/g' \
+ -i build-outputs.mk || die "sed failed"
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ $(use_with apache2 apache-libexecdir)
+ $(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
+ $(use_with berkdb berkeley-db "db.h:${EPREFIX}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
+ --without-ctypesgen
+ --disable-runtime-module-search
+ $(use_with keyring gnome-keyring)
+ $(use_enable java javahl)
+ $(use_with java jdk "${JAVA_HOME}")
+ $(use_enable nls)
+ $(use_enable plaintext-password-storage)
+ $(use_with sasl)
+ --with-serf
+ --with-apr="${EPREFIX}/usr/bin/apr-1-config"
+ --with-apr-util="${EPREFIX}/usr/bin/apu-1-config"
+ --disable-experimental-libtool
+ --without-jikes
+ --disable-mod-activation
+ --disable-static
+ --enable-svnxx
+ --without-swig-python
+ )
+
+ if use kwallet ; then
+ myconf+=( "--with-kwallet=/usr/include/:/usr/$(get_libdir)/" )
+ else
+ myconf+=( --without-kwallet )
+ fi
+
+ if use perl; then
+ myconf+=( --with-swig-perl )
+ else
+ myconf+=( --without-swig-perl )
+ fi
+
+ if use ruby; then
+ myconf+=( --with-swig-ruby="${EPREFIX}/usr/bin/ruby${RB_VER}" )
+ else
+ myconf+=( --without-swig-ruby )
+ fi
+
+ if use java ; then
+ myconf+=( --without-junit )
+ fi
+
+ case ${CHOST} in
+ *-solaris*)
+ # need -lintl to link
+ use nls && append-libs intl
+ # this breaks installation, on x64 echo replacement is 32-bits
+ myconf+=( --disable-local-library-preloading )
+ ;;
+ *)
+ # inject LD_PRELOAD entries for easy in-tree development
+ myconf+=( --enable-local-library-preloading )
+ ;;
+ esac
+
+ # version 1.7.7 again tries to link against the older installed version and fails, when trying to
+ # compile for x86 on amd64, so workaround this issue again
+ # check newer versions, if this is still/again needed
+ #myconf+=( --disable-disallowing-of-undefined-references )
+
+ # for build-time scripts
+ if use test; then
+ python_setup
+ fi
+
+ ac_cv_path_RUBY=$(usex ruby "${EPREFIX}/usr/bin/ruby${RB_VER}" "none") \
+ ac_cv_path_RDOC=$(usex ruby "${EPREFIX}/usr/bin/rdoc${RB_VER}" "none") \
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake local-all
+
+ if use perl ; then
+ emake swig-pl
+ fi
+
+ if use ruby ; then
+ emake swig-rb
+ fi
+
+ if use java ; then
+ emake -j1 JAVAC_FLAGS="$(java-pkg_javac-args) -encoding iso8859-1" javahl
+ fi
+
+ if use extras ; then
+ emake tools
+ fi
+
+ if use doc ; then
+ doxygen doc/doxygen.conf || die "Building of Subversion HTML documentation failed"
+
+ if use java; then
+ emake doc-javahl
+ fi
+ fi
+}
+
+src_test() {
+ # TODO: Maybe run swig tests for each language?
+ #if has_version ~${CATEGORY}/${P} ; then
+ emake -Onone PARALLEL="$(makeopts_jobs)" check
+ #else
+ # ewarn "The test suite shows errors when there is an older version of"
+ # ewarn "${CATEGORY}/${PN} installed. Please install =${CATEGORY}/${P}*"
+ # ewarn "before running the test suite."
+ # ewarn "Test suite skipped."
+ #fi
+
+ if [[ -f "${S}/fails.log" ]] ; then
+ echo "====== contents of fails.log follow ======"
+ cat "${S}/fails.log" || die
+ echo "====== contents of fails.log end ======"
+ fi
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" local-install
+
+ if use perl ; then
+ emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl
+ perl_delete_localpod
+ find "${ED}" \( -name .packlist -o -name "*.bs" \) -delete || die
+ fi
+
+ if use ruby ; then
+ emake DESTDIR="${D}" install-swig-rb
+ fi
+
+ if use java ; then
+ emake DESTDIR="${D}" install-javahl
+ java-pkg_regso "${ED}"/usr/$(get_libdir)/libsvnjavahl*$(get_libname)
+ java-pkg_dojar "${ED}"/usr/$(get_libdir)/svn-javahl/svn-javahl.jar
+ rm -fr "${ED}"/usr/$(get_libdir)/svn-javahl/*.jar
+ fi
+
+ # Install Apache module configuration.
+ if use apache2 ; then
+ keepdir "${APACHE_MODULES_CONFDIR}"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/47_mod_dav_svn.conf"
+ fi
+
+ # Install bash completion, bug #43179.
+ newbashcomp tools/client-side/bash_completion svn
+ bashcomp_alias svn svn{admin,dumpfilter,look,sync,version}
+ rm -f tools/client-side/bash_completion || die
+
+ # Install hot backup script, bug #54304.
+ newbin tools/backup/hot-backup.py svn-hot-backup
+ rm -fr tools/backup || die
+
+ # Install svnserve init-script and xinet.d snippet, bug #43245.
+ newinitd "${FILESDIR}"/svnserve.initd3 svnserve
+ newconfd "${FILESDIR}"/svnserve.confd svnserve
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/svnserve.xinetd svnserve
+
+ # Adjust default user and group with disabled apache2 USE flag, bug #381385
+ if ! use apache2 ; then
+ sed -e "s\USER:-apache\USER:-svn\g" \
+ -e "s\GROUP:-apache\GROUP:-svnusers\g" \
+ -i "${ED}"/etc/init.d/svnserve || die
+ sed -e "0,/apache/s//svn/" \
+ -e "s:apache:svnusers:" \
+ -i "${ED}"/etc/xinetd.d/svnserve || die
+ fi
+
+ # Install documentation.
+ dodoc CHANGES COMMITTERS README
+ dodoc tools/xslt/svnindex.{css,xsl}
+ rm -fr tools/xslt
+
+ # Install extra files.
+ if use extras ; then
+ cat <<- EOF > 80subversion-extras
+ PATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ ROOTPATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ EOF
+ doenvd 80subversion-extras
+
+ emake DESTDIR="${D}" toolsdir="/usr/$(get_libdir)/subversion/bin" install-tools
+
+ find tools \( -name "*.bat" -o -name "*.in" -o -name ".libs" \) -print0 | xargs -0 rm -fr
+ rm -fr tools/client-side/svnmucc
+ rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
+ rm -fr tools/{buildbot,dev,diff,po}
+ fi
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/doxygen/html/*
+
+ if use java ; then
+ java-pkg_dojavadoc doc/javadoc
+ fi
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ cd "${ED}"/usr/share/locale
+ for i in * ; do
+ if [[ ${i} != *${LINGUAS}* ]] ; then
+ rm -r ${i} || die
+ fi
+ done
+}
+
+pkg_preinst() {
+ # Compare versions of Berkeley DB, bug #122877.
+ if use berkdb && [[ -f "${EROOT}/usr/bin/svn" ]] ; then
+ OLD_BDB_VERSION="$(scanelf -nq "${EROOT}/usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ NEW_BDB_VERSION="$(scanelf -nq "${ED}/usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ if [[ "${OLD_BDB_VERSION}" != "${NEW_BDB_VERSION}" ]] ; then
+ CHANGED_BDB_VERSION="1"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if [[ -n "${CHANGED_BDB_VERSION}" ]] ; then
+ ewarn "You upgraded from an older version of Berkeley DB and may experience"
+ ewarn "problems with your repository. Run the following commands as root to fix it:"
+ ewarn " db4_recover -h ${SVN_REPOS_LOC}/repos"
+ ewarn " chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
+ fi
+
+ ewarn "If you run subversion as a daemon, you will need to restart it to avoid module mismatches."
+}
+
+pkg_postrm() {
+ :
+}
+
+pkg_config() {
+ # Remember: Don't use ${EROOT}${SVN_REPOS_LOC} since ${SVN_REPOS_LOC}
+ # already has EPREFIX in it
+ einfo "Initializing the database in ${SVN_REPOS_LOC}..."
+ if [[ -e "${SVN_REPOS_LOC}/repos" ]] ; then
+ echo "A Subversion repository already exists and I will not overwrite it."
+ echo "Delete \"${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
+ else
+ mkdir -p "${SVN_REPOS_LOC}/conf"
+
+ einfo "Populating repository directory..."
+ # Create initial repository.
+ "${EROOT}/usr/bin/svnadmin" create "${SVN_REPOS_LOC}/repos"
+
+ einfo "Setting repository permissions..."
+ SVNSERVE_USER="$(. "${EROOT}/etc/conf.d/svnserve"; echo "${SVNSERVE_USER}")"
+ SVNSERVE_GROUP="$(. "${EROOT}/etc/conf.d/svnserve"; echo "${SVNSERVE_GROUP}")"
+ if use apache2 ; then
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="apache"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="apache"
+ else
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="svn"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="svnusers"
+ fi
+ chmod -Rf go-rwx "${SVN_REPOS_LOC}/conf"
+ chmod -Rf o-rwx "${SVN_REPOS_LOC}/repos"
+ chown -Rf ${SVNSERVE_USER}:${SVNSERVE_GROUP} "${SVN_REPOS_LOC}/repos"
+ fi
+}