summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-24 13:17:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-24 13:17:42 +0200
commitb79e40dcfe1e580f77830d2fbdf037433c4d81b6 (patch)
tree3ab88f321b3471d73c2033d3074d4cc692428749 /dev-vcs
parentx11-drivers/nvidia-drivers: Version 430.09 (diff)
downloadgentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.tar.gz
gentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.tar.bz2
gentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.zip
dev-vcs/git: Fixed build on uclibc systems with USE="iconv"
Thanks-to: René Rhéaume <rene.rheaume@gmail.com> Closes: https://bugs.gentoo.org/557122 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.19.2.ebuild4
-rw-r--r--dev-vcs/git/git-2.20.1.ebuild4
-rw-r--r--dev-vcs/git/git-2.21.0-r1.ebuild4
-rw-r--r--dev-vcs/git/git-2.21.0-r2.ebuild4
-rw-r--r--dev-vcs/git/git-2.21.0.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild4
-rw-r--r--dev-vcs/git/git-9999.ebuild4
9 files changed, 27 insertions, 9 deletions
diff --git a/dev-vcs/git/git-2.19.2.ebuild b/dev-vcs/git/git-2.19.2.ebuild
index 2485c41c5511..01a982d56b3d 100644
--- a/dev-vcs/git/git-2.19.2.ebuild
+++ b/dev-vcs/git/git-2.19.2.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs}"
diff --git a/dev-vcs/git/git-2.20.1.ebuild b/dev-vcs/git/git-2.20.1.ebuild
index 578fe8036f58..6164d3b78d7b 100644
--- a/dev-vcs/git/git-2.20.1.ebuild
+++ b/dev-vcs/git/git-2.20.1.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs}"
diff --git a/dev-vcs/git/git-2.21.0-r1.ebuild b/dev-vcs/git/git-2.21.0-r1.ebuild
index a46eb7533fd4..e6ce3acc0a0e 100644
--- a/dev-vcs/git/git-2.21.0-r1.ebuild
+++ b/dev-vcs/git/git-2.21.0-r1.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-2.21.0-r2.ebuild b/dev-vcs/git/git-2.21.0-r2.ebuild
index 0560e22b3ff2..7c26a1a93c15 100644
--- a/dev-vcs/git/git-2.21.0-r2.ebuild
+++ b/dev-vcs/git/git-2.21.0-r2.ebuild
@@ -244,8 +244,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-2.21.0.ebuild b/dev-vcs/git/git-2.21.0.ebuild
index 7144f46a58ea..632c8af1a3c0 100644
--- a/dev-vcs/git/git-2.21.0.ebuild
+++ b/dev-vcs/git/git-2.21.0.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 5d6ae9ba9b66..62eaae028495 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 5d6ae9ba9b66..62eaae028495 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 5d6ae9ba9b66..62eaae028495 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 5d6ae9ba9b66..62eaae028495 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"