summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-09-25 14:52:19 +0100
committerYixun Lan <dlan@gentoo.org>2021-09-26 16:50:21 +0800
commitb3a791ce4d2681f2c5e93809ad01a413daf99684 (patch)
tree4c309fa2bedc84732d38d49ce2e5b52b02ffc9c2 /dev-vcs
parentdev-util/lttng-tools: version bump, 2.12.5/2.13.0 (diff)
downloadgentoo-b3a791ce4d2681f2c5e93809ad01a413daf99684.tar.gz
gentoo-b3a791ce4d2681f2c5e93809ad01a413daf99684.tar.bz2
gentoo-b3a791ce4d2681f2c5e93809ad01a413daf99684.zip
dev-vcs/git-pw: Bump to 2.1.1
Closes: https://bugs.gentoo.org/804519 Closes: https://github.com/gentoo/gentoo/pull/22398 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.1.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index 9911bd4fe414..20159044bf9c 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1 +1,2 @@
DIST git-pw-2.0.0.tar.gz 32151 BLAKE2B f8ef04b31cb4457ac9bae333bae65deb7d17469cd25a3724a27201dab0c05f98151a5ec1066cb9d2de81d82360f4e46eaa59ebd08904dfa0d16106f589e17e4c SHA512 83ac4d56091bfe9b03733939fb3e4feab22ce4455eebe8508bc730705b69054a2f060cfb8a1ea469476d9519809a89116ff56210efe4cd76e50df5a5d40886fc
+DIST git-pw-2.1.1.tar.gz 32489 BLAKE2B 516eb3b81c3798a455b7122a3b0ad9bf0d9722eb6f301ea58ed766cca94137f4da4eaf34a40ec7c5e108368aa6099f9401aba6d71d463913cd2b7fd9dc7aef09 SHA512 3cbf0670bf811d6b6ef0d4c5c7ad4321380d442c62fd15869758b26b4fc375c2d4bd2bdbf693a41d0cbe862bdef15fc02d04124a089f7786bd1b2e56f818e0c2
diff --git a/dev-vcs/git-pw/git-pw-2.1.1.ebuild b/dev-vcs/git-pw/git-pw-2.1.1.ebuild
new file mode 100644
index 000000000000..a27a91f9a2c5
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}
+distutils_enable_tests pytest