summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-30 06:16:32 +0000
committerSam James <sam@gentoo.org>2024-01-30 06:16:38 +0000
commit1f55b047a4def23e1922c1be26767f00e7ef28b8 (patch)
tree65c68152aa625879f4ddecf8f273196bcbdf1d78 /dev-vcs
parentdev-vcs/git-filter-repo: simplify BDEPEND assignment (diff)
downloadgentoo-1f55b047a4def23e1922c1be26767f00e7ef28b8.tar.gz
gentoo-1f55b047a4def23e1922c1be26767f00e7ef28b8.tar.bz2
gentoo-1f55b047a4def23e1922c1be26767f00e7ef28b8.zip
dev-vcs/git-filter-repo: fix VariableOrderWrong
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild3
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
index c421873e3a78..710545220a60 100644
--- a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
@@ -9,6 +9,7 @@ inherit distutils-r1
DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
HOMEPAGE="https://github.com/newren/git-filter-repo/"
SRC_URI="https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz"
+S="${S}/release"
LICENSE="MIT"
SLOT="0"
@@ -23,8 +24,6 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"
-S="${S}/release"
-
python_prepare_all() {
cat > PKG-INFO <<-EOF || die
Metadata-Version: 2.1
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild
index 3dab0bdca4d9..4155adf57f1e 100644
--- a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild
@@ -9,6 +9,7 @@ inherit distutils-r1
DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
HOMEPAGE="https://github.com/newren/git-filter-repo/"
SRC_URI="https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz"
+S="${S}/release"
LICENSE="MIT"
SLOT="0"
@@ -23,8 +24,6 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"
-S="${S}/release"
-
# the git-archive tarball does not have version info; setuptools-scm
# requires a valid source of version info, this one is for distros
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}