summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2018-06-27 16:28:27 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2018-06-27 16:33:15 +0200
commit1bdeca97a5867baa2aea18aad2e0332cc25b9276 (patch)
tree988c3bbea4d1bce6612a3c04548a3e8d32502e81 /dev-vcs
parentwww-client/opera-beta: Old. (diff)
downloadgentoo-1bdeca97a5867baa2aea18aad2e0332cc25b9276.tar.gz
gentoo-1bdeca97a5867baa2aea18aad2e0332cc25b9276.tar.bz2
gentoo-1bdeca97a5867baa2aea18aad2e0332cc25b9276.zip
dev-vcs/git-lfs: Version bump to 2.4.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.4.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index d044b492ced6..b992c3bc44c9 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -2,3 +2,4 @@ DIST git-lfs-1.5.6.tar.gz 604139 BLAKE2B a87c3054a5ff354409581f3153b8291646c7a40
DIST git-lfs-2.1.1.tar.gz 649611 BLAKE2B 6a2a499ac446cfbf04977ff56ba0c33ac49f4cfd8d269a4e16e9d15ef7010752fcdc439e09625b76c814ba1b3c3bc086c333ad44ff87da8288da86a31c19cf17 SHA512 9061cb9fdf93a0c119d5762ceebdbc0573491dedb1815512e7eae9da54574087c1e499ea97ba0a87d7356499314beb53d60d1800b5c85983ef835dae37e7dd84
DIST git-lfs-2.2.1.tar.gz 708806 BLAKE2B f5527c45a9b2415b9c17be8bf8ff04ea1d324cef74fe72ff9c91b5831d3b866d6dd57ab047addc762a4ad84d8f92e1a8dd5a2c21a532c4dffe2f7b3675463217 SHA512 8e1edd588916e6a09c0fe84bdcd80b8773f3874554f941c65819bbb29cdce4846de6408dbb34b33e420d9bc768f6cd07c2dbb0979d243c98f25a32d4fc69dea4
DIST git-lfs-2.3.4.tar.gz 747313 BLAKE2B c1b2d452894c07974f9857116cab4f2aad547584b6d713824103b2e7f82c8179146a080330ee1154369c22843766a63a09ce1f990c968b55dce9eccc7a306302 SHA512 97174dc9346979777c3951baa86cfc07c85e2df04f13a50114e016facbb3fd5fde08d38825493d4e7ff149a13c87ae44e9e40350cd4950f27fe309ef62b6724a
+DIST git-lfs-2.4.2.tar.gz 791443 BLAKE2B 6c613ad5b644f609b36a6a5c569c3512713d0f5fc925be759b20a01ca0e57573246557e887e086b52c5703db9db4d8a49fe91761efec48410738724256cac9e9 SHA512 c89a15c36b9d52091eb6e89f8e1db23b03f35333794467432ee49728ba83fc5d25d238f5df49bf736a4a3079778d70a527db01c2299ecd96a7b5f70059616967
diff --git a/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild b/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild
new file mode 100644
index 000000000000..a3aad04e586d
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}