summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-10-13 09:47:50 +0100
committerMarek Szuba <marecki@gentoo.org>2022-10-13 10:31:04 +0100
commit22399525f2be96810b902549a47dc01bc96105fc (patch)
tree588c81eede1dba2a6ac595cc5f738680846cf149 /dev-vcs/git-machete
parentx11-libs/neXtaw: EAPI7->8, fix w/ clang16, -std=gnu89 + -fno-strict (diff)
downloadgentoo-22399525f2be96810b902549a47dc01bc96105fc.tar.gz
gentoo-22399525f2be96810b902549a47dc01bc96105fc.tar.bz2
gentoo-22399525f2be96810b902549a47dc01bc96105fc.zip
dev-vcs/git-machete: add 3.12.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/git-machete')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.12.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index 21800fb2f37e..8f5f2702abf3 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1 +1,2 @@
DIST git-machete-3.12.1.gh.tar.gz 1380396 BLAKE2B 37ba33e7f3d2400c9509c5fb7c11467ebbdbcdb35d0f4a138649a872322bdfa9c22e3711b68b2862f9ff036d1746c0aaac968d6f61df5187553d4713a7cfd532 SHA512 6aab18c8930244c37a320cf920ebbd66c7839f792b1b0ea3156ab7c4222d5fe7e7646b053f8d919ee5189c918b1a4329ddd665a4a1a9d568db9f935bb8b51984
+DIST git-machete-3.12.4.gh.tar.gz 1381813 BLAKE2B 2eb0f8d72fe82cd68bf8f778979ed8a14c2cfd9e752f02f3c0c69e53000c5f8877c433fdaa461f988545e60687d5516c28ee7de0eb2bfd1bc377fcc129425c6b SHA512 39217be678d1cc2fa52a314ebeabf127e71ae130dcbdc8a93bdd075e3130ca2ce2464e153367f8eccc61315234cfe39ec675920eca4599dca41167abc195c1d4
diff --git a/dev-vcs/git-machete/git-machete-3.12.4.ebuild b/dev-vcs/git-machete/git-machete-3.12.4.ebuild
new file mode 100644
index 000000000000..9c6b4673cedb
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.12.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}