summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-11 01:55:44 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-11 08:59:17 +0100
commitae35262c1fa6fbbb2a444642070dbb912df28f89 (patch)
treedc2e27ef996ad7705bb7159aafbdaa5900c1da4c /dev-util
parentsys-kernel/git-sources: Linux patch 4.15-rc3 (diff)
downloadgentoo-ae35262c1fa6fbbb2a444642070dbb912df28f89.tar.gz
gentoo-ae35262c1fa6fbbb2a444642070dbb912df28f89.tar.bz2
gentoo-ae35262c1fa6fbbb2a444642070dbb912df28f89.zip
dev-util/pycharm-community: Update icon and .desktop caches.
Closes: https://github.com/gentoo/gentoo/pull/6434/ Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild16
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.2.4.ebuild16
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.3.ebuild16
3 files changed, 39 insertions, 9 deletions
diff --git a/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild b/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild
index bc2aa0e1908c..bcd9bbba0a3f 100644
--- a/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild
+++ b/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils readme.gentoo-r1
+inherit gnome2-utils xdg-utils readme.gentoo-r1
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
@@ -38,8 +38,18 @@ src_install() {
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
- newicon "bin/${MY_PN}.png" ${PN}.png
- make_desktop_entry ${PN} "${PN}" "${PN}"
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/pycharm-community/pycharm-community-2017.2.4.ebuild b/dev-util/pycharm-community/pycharm-community-2017.2.4.ebuild
index 6bcb19218d4c..6dfa17b1da1f 100644
--- a/dev-util/pycharm-community/pycharm-community-2017.2.4.ebuild
+++ b/dev-util/pycharm-community/pycharm-community-2017.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils readme.gentoo-r1
+inherit gnome2-utils xdg-utils readme.gentoo-r1
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
@@ -38,8 +38,18 @@ src_install() {
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
- newicon "bin/${MY_PN}.png" ${PN}.png
- make_desktop_entry ${PN} "${PN}" "${PN}"
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/pycharm-community/pycharm-community-2017.3.ebuild b/dev-util/pycharm-community/pycharm-community-2017.3.ebuild
index 6bcb19218d4c..6dfa17b1da1f 100644
--- a/dev-util/pycharm-community/pycharm-community-2017.3.ebuild
+++ b/dev-util/pycharm-community/pycharm-community-2017.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils readme.gentoo-r1
+inherit gnome2-utils xdg-utils readme.gentoo-r1
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
@@ -38,8 +38,18 @@ src_install() {
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
- newicon "bin/${MY_PN}.png" ${PN}.png
- make_desktop_entry ${PN} "${PN}" "${PN}"
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}