summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-23 21:16:07 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-24 17:26:05 +0200
commit635cb3b6a65f29ae00b50458406581fc1d940334 (patch)
tree506b303665f23311f16ac349b92c657b4c8e1df6 /dev-util
parentnet-im/gajim: drop myself as a maintainer (diff)
downloadgentoo-635cb3b6a65f29ae00b50458406581fc1d940334.tar.gz
gentoo-635cb3b6a65f29ae00b50458406581fc1d940334.tar.bz2
gentoo-635cb3b6a65f29ae00b50458406581fc1d940334.zip
dev-util/ostree: add 2024.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/ostree-2024.3.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index df5f83f8b352..85fcb80f2d3e 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -2,3 +2,4 @@ DIST ostree-2023.1.tar.xz 2079904 BLAKE2B 993570624cb43684d81fff9f3789a9cee3b998
DIST ostree-2023.2.tar.xz 2081320 BLAKE2B f773bf979b4bc97b9b8f96dc4385745bc386c29952a36c07cdd33a7db7802876ce154b5ac1f3669605ab3949a539aa8e2b3a3d94608557eb65249b5188f9d012 SHA512 549a2bdf8cef93d421aaf990e2d1c534063f0314b5933db7ce123bdd138229e24cc171d541296e45a7546a91d35149c1c8f29ea90949876200c574e7ec297b98
DIST ostree-2023.3.tar.xz 2075168 BLAKE2B 6e699420a89b36520e60a5682a421fd8f10eb20702abe6af97be9ee78a04be98e8d164157d29726de9e63b869051f7e60f199776ea3d959d4f0ad4165ff780c6 SHA512 af3b80d55e15b515e860ab0ee5f061f1a4d649b21441d5cde66e71ff4349ef480565cb795838ebce2f42784d53e349c2443159d9ee452277001d930ba814fe40
DIST ostree-2023.5.tar.xz 2115184 BLAKE2B ac1fa6764e1b7e5cd6656f2977b2605e3d2c612e6ee426fc8dbd7c84d6aebe72159943d7c2e53a2898aee6c085814228df772edc35b93daa23cb14bbb5642a6f SHA512 0bb19f199344d8db7299cf710f2ba0b2657cdcb5b1fc6d85446cef9538b069e470b47fc0c2c1029e12b8b9adb978f32a6f44f48949ff5c97a01051a425a9f2d5
+DIST ostree-2024.3.tar.xz 2141876 BLAKE2B 5a2639b99697eaf3f0a94d619c5121cb095bd21813af800041a9a4a077240ed4508c96fb67387f850a42bc4058c99d2d260ff66b0cee2fc89df64dae0b9b0508 SHA512 717e74bdaffe839acad68169d4a0290b3d81f2fb31329d02c507168b00b0b02928e2bb29c8c8fcef65a6581b98d9bad991adcde1579597b4be94822546c66573
diff --git a/dev-util/ostree/ostree-2024.3.ebuild b/dev-util/ostree/ostree-2024.3.ebuild
new file mode 100644
index 000000000000..295c98e3a0b9
--- /dev/null
+++ b/dev-util/ostree/ostree-2024.3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="
+ https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz
+ -> ${P}.tar.xz
+"
+S="${WORKDIR}/lib${P}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="archive +curl doc dracut gnutls +gpg grub +http2 httpd introspection libmount selinux sodium ssl +soup systemd zeroconf"
+RESTRICT="test"
+REQUIRED_USE="
+ dracut? ( systemd )
+ http2? ( curl )
+ httpd? ( || ( curl soup ) )
+"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/glib:2
+ sys-fs/fuse:3
+ sys-libs/zlib
+ archive? ( app-arch/libarchive:= )
+ curl? ( net-misc/curl )
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14:= )
+ soup? ( net-libs/libsoup:3.0 )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+BDEPEND="
+ dev-libs/libxslt
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/ostree-2023.3-dont-force-clang-introspection.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Needs Bison (bug #884289)
+ unset YACC
+
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut dracut yesbutnoconf) #816867
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup soup3)
+ --without-soup # libsoup:2.4
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=( --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" )
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ostree-tmpfiles.conf
+}