summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-01-30 08:59:20 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-01-30 09:23:58 +0100
commitdfea54649d360d514f784e347d840d165b585725 (patch)
treec05186e57cdd9ec7e813f1dfabae52b25599b96d /dev-util/uftrace
parentdev-util/uftrace: stabilize 0.14 for amd64 (diff)
downloadgentoo-dfea54649d360d514f784e347d840d165b585725.tar.gz
gentoo-dfea54649d360d514f784e347d840d165b585725.tar.bz2
gentoo-dfea54649d360d514f784e347d840d165b585725.zip
dev-util/uftrace: add 0.15.2
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/Manifest1
-rw-r--r--dev-util/uftrace/uftrace-0.15.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/uftrace/Manifest b/dev-util/uftrace/Manifest
index 4664550a6e33..f5fbd31195d1 100644
--- a/dev-util/uftrace/Manifest
+++ b/dev-util/uftrace/Manifest
@@ -1,2 +1,3 @@
DIST uftrace-0.13.1.tar.gz 1159973 BLAKE2B eafb5141f5c86a77d6c68fbb44d5575df62cb679ce037144eea4a76a6a729e9965f15437b5a3cbd3566d560d48946a7788970aa9e40ba86eb1cf39571ac30bfe SHA512 03033cc314fe902046eb8c7cdc8a15c6f67f7b4df189329ccb654041ec2e02baa03e6d3d8cbdf3238946096a3893f60ed105fe4807194a74f90a107400accd7f
DIST uftrace-0.14.tar.gz 1192139 BLAKE2B 81c83581351fc8b8302c312ad0a4d84a9f19c0db9253b31de6f2bb7e507aa8540eaab494ae1b52de3fd10baa4f2b658403676f1f53eeecb14f03c765b6fc98d0 SHA512 35fd121d0d0ac738a841deb470dd48b0a1a8a3d711b36463eddbbd8fc70122c76c5b5158ad2e92bd6a0b68f4bbe51c6957f4473f8b5be7ec82a9b962d31ffc5b
+DIST uftrace-0.15.2.tar.gz 1153687 BLAKE2B f9c4d7bb98b284534a96418d9d4adcee4b32b6b013052bbc6f34850ecc9262706e8e6fe79b2dfca88aaab5432c586e24ad783cdc50cf38792b8d758af2051295 SHA512 218072fc2a8c04c29b6ecbd61638db8824b0235cdb5e106e92e8fbe940fdb59d18c96c6b56830baa55b5dcda9f689a71755161313b101c6783c54be5c294993b
diff --git a/dev-util/uftrace/uftrace-0.15.2.ebuild b/dev-util/uftrace/uftrace-0.15.2.ebuild
new file mode 100644
index 000000000000..ffe4bfb99f16
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.15.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="capstone lua python unwind"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libelf:=
+ capstone? ( dev-libs/capstone:0= )
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
+ $(use_with capstone)
+ $(use_with unwind libunwind)
+ $(use_with python libpython)
+ )
+ if use lua && use lua_single_target_luajit; then
+ myconf+=(
+ --with-libluajit
+ )
+ else
+ myconf+=(
+ --without-libluajit
+ )
+ fi
+ CC="$(tc-getCC)" LD="$(tc-getLD)" econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ dodoc doc/*.{md,gif,png}
+ newbashcomp misc/bash-completion.sh uftrace
+}