summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/tailor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/tailor')
-rw-r--r--dev-util/tailor/Manifest1
-rw-r--r--dev-util/tailor/metadata.xml10
-rw-r--r--dev-util/tailor/tailor-0.9.35-r1.ebuild37
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/tailor/Manifest b/dev-util/tailor/Manifest
new file mode 100644
index 000000000000..2b5c38e44f48
--- /dev/null
+++ b/dev-util/tailor/Manifest
@@ -0,0 +1 @@
+DIST tailor-0.9.35.tar.gz 228650 SHA256 50b6eac61103636a9acb72a0b88e915dcc8baa1dcd9675e358aad8deaf622a18 SHA512 184521adac681ccca279215c115913d98d1521aac41fe15ca65a35e3c5075419e1cb0f1b453bca6d5a56a15b09928c34738a264b44f666de7067b2aba0562bed WHIRLPOOL 3ec5acbaa0418eff6c964253e5c7abab267e2a32c66e833192e7492cc16e1da8a8c29a98859e96c776fa3154ddb523d863f27b4872ac6ea1efc5b465375a10e7
diff --git a/dev-util/tailor/metadata.xml b/dev-util/tailor/metadata.xml
new file mode 100644
index 000000000000..3df908a9c339
--- /dev/null
+++ b/dev-util/tailor/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Tailor is a tool to migrate changesets between ArX, Bazaar,
+ Bazaar-NG, CVS, Codeville, Darcs, Git, Mercurial, Monotone,
+ Subversion and Tla repositories.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/tailor/tailor-0.9.35-r1.ebuild b/dev-util/tailor/tailor-0.9.35-r1.ebuild
new file mode 100644
index 000000000000..2210c213c470
--- /dev/null
+++ b/dev-util/tailor/tailor-0.9.35-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to migrate changesets between version control systems"
+HOMEPAGE="http://wiki.darcs.net/index.html/Tailor"
+SRC_URI="http://darcs.arstecnica.it/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_install_all() {
+ local HTML_DOCS=( README.html )
+ distutils-r1_python_install_all
+ rm "${D}usr/share/doc/${PF}/README.html"
+}
+
+pkg_postinst() {
+ elog "Tailor does not explicitly depend on any other VCS."
+ elog "You should emerge whatever VCS(s) that you want to use seperately."
+}