summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <commendsarnex@gmail.com>2018-03-23 21:55:47 -0400
committerMatt Turner <mattst88@gentoo.org>2018-04-14 12:50:21 -0700
commitdf0dd63d433b2d3325679014524b205434f698d7 (patch)
tree2b0da4f0c921a7e76a0a841b5d70b88afe415e8c /dev-util/spirv-tools/spirv-tools-9999.ebuild
parentsys-apps/ethtool: Removed old. (diff)
downloadgentoo-df0dd63d433b2d3325679014524b205434f698d7.tar.gz
gentoo-df0dd63d433b2d3325679014524b205434f698d7.tar.bz2
gentoo-df0dd63d433b2d3325679014524b205434f698d7.zip
dev-util/spirv-tools: Revbump and add a header that includes git SHA1 for vulkan-loader
Closes: https://github.com/gentoo/gentoo/pull/7599
Diffstat (limited to 'dev-util/spirv-tools/spirv-tools-9999.ebuild')
-rw-r--r--dev-util/spirv-tools/spirv-tools-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-util/spirv-tools/spirv-tools-9999.ebuild b/dev-util/spirv-tools/spirv-tools-9999.ebuild
index e6ecb91d83e6..e0e2f53d0e21 100644
--- a/dev-util/spirv-tools/spirv-tools-9999.ebuild
+++ b/dev-util/spirv-tools/spirv-tools-9999.ebuild
@@ -23,3 +23,12 @@ multilib_src_configure() {
cmake-utils_src_configure
}
+
+multilib_src_install() {
+ default
+
+ # create a header file with the commit hash of the current revision
+ # vulkan-tools needs this to build
+ local revision="$(git-r3_peek_remote_ref)" &> /dev/null
+ echo "${revision}" > "${D}/usr/include/${PN}/${PN}-commit.h" || die
+}