summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-22 16:46:25 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-22 22:58:35 -0400
commit783f653d7c418e6fac748ebda5aef2ceb33ac66d (patch)
treec56dbe542c19ed24ce791b282375ed9ffe727d96 /dev-util/spirv-llvm-translator
parentdev-util/spirv-llvm-translator: Move spirv-headers out of RDEPEND (diff)
downloadgentoo-783f653d7c418e6fac748ebda5aef2ceb33ac66d.tar.gz
gentoo-783f653d7c418e6fac748ebda5aef2ceb33ac66d.tar.bz2
gentoo-783f653d7c418e6fac748ebda5aef2ceb33ac66d.zip
dev-util/spirv-llvm-translator: Remove IUSE=tools
It has not worked since upstream commit ae904012 ("[CMake] Enable LLVM_BUILD_TOOLS for out-of-tree builds") in v15.0.0. With that commit reverted, USE=-tools saves building one 120 KiB executable (llvm-spirv) which is a single source file. Also unconditionally depend on dev-util/spirv-tools as it is an automagic dependency of llvm-spirv which will always be installed for consumers of dev-util/spirv-llvm-translator. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/spirv-llvm-translator')
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild5
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
index cdd464fdb974..44eef063ff8c 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
@@ -17,11 +17,11 @@ S="${WORKDIR}/${MY_P}"
LICENSE="UoI-NCSA"
SLOT="$(ver_cut 1)"
KEYWORDS="amd64 ~riscv ~x86"
-IUSE="test +tools"
-REQUIRED_USE="test? ( tools )"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
+ dev-util/spirv-tools
sys-devel/llvm:${SLOT}
"
DEPEND="${RDEPEND}
@@ -45,7 +45,6 @@ src_configure() {
-DCCACHE_ALLOWED="OFF"
-DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="${ESYSROOT}/usr/include/spirv"
- -DLLVM_BUILD_TOOLS=$(usex tools "ON" "OFF")
-DLLVM_SPIRV_INCLUDE_TESTS=$(usex test "ON" "OFF")
-Wno-dev
)
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild
index 7cf49ee565d2..1660126d9c5f 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-16.0.0-r1.ebuild
@@ -17,11 +17,11 @@ S="${WORKDIR}/${MY_P}"
LICENSE="UoI-NCSA"
SLOT="$(ver_cut 1)"
KEYWORDS="~amd64 ~x86"
-IUSE="test +tools"
-REQUIRED_USE="test? ( tools )"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
+ dev-util/spirv-tools
sys-devel/llvm:${SLOT}
"
DEPEND="${RDEPEND}
@@ -50,7 +50,6 @@ src_configure() {
-DCCACHE_ALLOWED="OFF"
-DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="${ESYSROOT}/usr/include/spirv"
- -DLLVM_BUILD_TOOLS=$(usex tools "ON" "OFF")
-DLLVM_SPIRV_INCLUDE_TESTS=$(usex test "ON" "OFF")
-Wno-dev
)