summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-01-18 21:38:04 +0800
committerJoonas Niilola <juippis@gentoo.org>2023-01-27 09:33:23 +0200
commit22c48cd7dccb5c69de56408c43d35a1a212c8f31 (patch)
treecd9f787cb9299ddd81f49bf67229d1f2e4813b6a /dev-util/rocm-smi
parentdev-util/rocm-smi: add 5.4.2 (diff)
downloadgentoo-22c48cd7dccb5c69de56408c43d35a1a212c8f31.tar.gz
gentoo-22c48cd7dccb5c69de56408c43d35a1a212c8f31.tar.bz2
gentoo-22c48cd7dccb5c69de56408c43d35a1a212c8f31.zip
dev-util/rocm-smi: update patch, LICENSE, PYTHON_COMPAT on 9999
Use newest patch from version 5.4.2 Clean up unnecessary sed commands like 5.4.2 Closes: https://bugs.gentoo.org/890646 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29157 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/rocm-smi')
-rw-r--r--dev-util/rocm-smi/rocm-smi-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-util/rocm-smi/rocm-smi-9999.ebuild b/dev-util/rocm-smi/rocm-smi-9999.ebuild
index 8d35ce910b8b..bc4f8b802371 100644
--- a/dev-util/rocm-smi/rocm-smi-9999.ebuild
+++ b/dev-util/rocm-smi/rocm-smi-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake multilib prefix python-r1
+inherit cmake python-r1
DESCRIPTION="ROCm System Management Interface Library"
HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_smi_lib"
@@ -20,7 +20,7 @@ else
S="${WORKDIR}/rocm_smi_lib-rocm-${PV}"
fi
-LICENSE="NCSA-AMD"
+LICENSE="MIT NCSA-AMD"
SLOT="0/$(ver_cut 1-2)"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -29,22 +29,23 @@ DEPEND=""
RDEPEND="${PYTHON_DEPS}"
BDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.2-gcc12-memcpy.patch
+ "${FILESDIR}"/${PN}-5.4.2-detect-builtin-amdgpu.patch
+)
+
src_prepare() {
- sed -e "/DESTINATION/s,\${OAM_NAME}/lib,$(get_libdir)," \
- -e "/DESTINATION/s,oam/include/oam,include/oam," -i oam/CMakeLists.txt || die
- sed -e "/link DESTINATION/,+1d" \
- -e "/DESTINATION/s,\${ROCM_SMI}/lib,$(get_libdir)," \
- -e "/bindings_link/,+3d" \
- -e "/rsmiBindings.py/,+1d" \
- -e "/DESTINATION/s,rocm_smi/include/rocm_smi,include/rocm_smi," -i rocm_smi/CMakeLists.txt || die
- sed -e "/LICENSE.txt/d" -e "s,\${ROCM_SMI}/lib/cmake,$(get_libdir)/cmake,g" -i CMakeLists.txt || die
- sed -e "/^path_librocm = /c\path_librocm = '${EPREFIX}/usr/lib64/librocm_smi64.so'" -i python_smi_tools/rsmiBindings.py || die
+ sed -e "/LICENSE.txt/d" -i CMakeLists.txt || die
+ sed -e "/^path_librocm = /c\path_librocm = '${EPREFIX}/usr/lib64/librocm_smi64.so'" \
+ -i python_smi_tools/rsmiBindings.py || die
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_DISABLE_FIND_PACKAGE_LATEX=ON
+ -DFILE_REORG_BACKWARD_COMPATIBILITY=OFF
)
cmake_src_configure
}