summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-11-03 13:57:06 +0100
committerJeroen Roovers <jer@gentoo.org>2018-11-03 15:04:26 +0100
commite840a059eb9f05319b6bc22d9891151617ea6475 (patch)
tree2fc7db270a3ddd1cdfbc886f4477e98aa4c8cbcd /dev-util/redo/redo-0.21.ebuild
parentdev-tcltk/tls: Version bump to 1.7.16 (diff)
downloadgentoo-e840a059eb9f05319b6bc22d9891151617ea6475.tar.gz
gentoo-e840a059eb9f05319b6bc22d9891151617ea6475.tar.bz2
gentoo-e840a059eb9f05319b6bc22d9891151617ea6475.zip
dev-util/redo: Initial commit
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-util/redo/redo-0.21.ebuild')
-rw-r--r--dev-util/redo/redo-0.21.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/redo/redo-0.21.ebuild b/dev-util/redo/redo-0.21.ebuild
new file mode 100644
index 000000000000..a109d053e056
--- /dev/null
+++ b/dev-util/redo/redo-0.21.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+inherit multilib python-single-r1
+
+DESCRIPTION="Smaller, easier, more powerful, and more reliable than make"
+HOMEPAGE="https://github.com/apenwarr/redo"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+DEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+S=${WORKDIR}/${PN}-${P}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="${D}/usr/share/doc/${PF}" \
+ LIBDIR="${D}/usr/$(get_libdir)/${PN}" \
+ install
+
+ python_fix_shebang "${D}"
+
+ sed -i \
+ -e 's|/lib/|/'"$(get_libdir)"'/|g' \
+ "${D}"/usr/bin/* || die
+}