summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-04-28 11:03:14 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-04-28 11:03:14 +0100
commit7386700e147b1a3243661701813726832438f040 (patch)
treee109e47538d9c7406333bbd4c97afea9f5afd037 /dev-util/radare2
parentsys-libs/lwp: stable 2.8 for ia64, bug #654098 (diff)
downloadgentoo-7386700e147b1a3243661701813726832438f040.tar.gz
gentoo-7386700e147b1a3243661701813726832438f040.tar.bz2
gentoo-7386700e147b1a3243661701813726832438f040.zip
dev-util/radare2: synch completion handling to live ebuild
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-util/radare2')
-rw-r--r--dev-util/radare2/radare2-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-util/radare2/radare2-9999.ebuild b/dev-util/radare2/radare2-9999.ebuild
index e7a0aae0342f..89e71ebcc423 100644
--- a/dev-util/radare2/radare2-9999.ebuild
+++ b/dev-util/radare2/radare2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+inherit eutils bash-completion-r1
DESCRIPTION="unix-like reverse engineering framework and commandline tools"
HOMEPAGE="http://www.radare.org"
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="ssl libressl +system-capstone zsh-completion"
+IUSE="ssl libressl +system-capstone"
RDEPEND="
ssl? (
@@ -41,10 +41,11 @@ src_configure() {
src_install() {
default
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
- fi
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+
+ newbashcomp doc/bash_autocompletion.sh "${PN}"
+ bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
# a workaround for unstable $(INSTALL) call, bug #574866
local d