summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-02-03 22:24:55 +0100
committerSam James <sam@gentoo.org>2022-02-20 00:29:53 +0000
commit5973f2fdaef90add74d849934d5b96ab48dafa6e (patch)
tree02d981c3ab7be7b3cf5d2e432f524036d6649702 /dev-util/its4
parentdev-util/its4: Avoid calling g++ directly (diff)
downloadgentoo-5973f2fdaef90add74d849934d5b96ab48dafa6e.tar.gz
gentoo-5973f2fdaef90add74d849934d5b96ab48dafa6e.tar.bz2
gentoo-5973f2fdaef90add74d849934d5b96ab48dafa6e.zip
dev-util/its4: Fix build for clang/LLVM toolchain
The config.C file has five instances of string literals being immediately followed by NEWLINE (a macro that expands to another string literal). C++11 requires a space between string literals. Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://bugs.gentoo.org/738936 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/its4')
-rw-r--r--dev-util/its4/its4-1.1.1-r2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/its4/its4-1.1.1-r2.ebuild b/dev-util/its4/its4-1.1.1-r2.ebuild
index 5bb0c4ed44fc..86e78a42d315 100644
--- a/dev-util/its4/its4-1.1.1-r2.ebuild
+++ b/dev-util/its4/its4-1.1.1-r2.ebuild
@@ -22,6 +22,11 @@ src_prepare() {
sed -i \
-e 's/$(CC) -o/$(CC) $(OPTIMIZATION) $(EXTRA_FLAGS) -o/' \
"${S}"/Makefile.in || die
+
+ # Bug 738936 fails to compile with clang/LLVM toolchain
+ sed -i \
+ -e 's/"NEWLINE/" NEWLINE/g'\
+ "${S}"/config.C || die
eapply_user
}