summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-03-30 11:01:47 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-03-30 11:29:49 -0700
commit4d7bcfa241bab041f0b924c534db5fe9b7e53877 (patch)
tree5f5848c0d9fdd3d3518c5ff0de5c6b43161822c8 /dev-util/its4
parentdev-python/docopt: cleaning 0.6.2 (diff)
downloadgentoo-4d7bcfa241bab041f0b924c534db5fe9b7e53877.tar.gz
gentoo-4d7bcfa241bab041f0b924c534db5fe9b7e53877.tar.bz2
gentoo-4d7bcfa241bab041f0b924c534db5fe9b7e53877.zip
dev-util/its4: LDFLAGS, Manifests, license
- LDFLAGS/g++/EAPI/keywords fix from Michael Mair-Keimberger (iamnr3) <bu9zilla@gmail.com>, per bug #337724. - Update Manifests to include WHIRLPOOL & SHA256 per bug 612732. - License Review: fetch & unmodified mirroring is permitted. Fixes: https://bugs.gentoo.org/show_bug.cgi?id=337724 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=612732 Package-Manager: portage-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-util/its4')
-rw-r--r--dev-util/its4/Manifest2
-rw-r--r--dev-util/its4/its4-1.1.1-r1.ebuild45
-rw-r--r--dev-util/its4/its4-1.1.1.ebuild8
3 files changed, 47 insertions, 8 deletions
diff --git a/dev-util/its4/Manifest b/dev-util/its4/Manifest
index c42070e059d3..47c4c8d99139 100644
--- a/dev-util/its4/Manifest
+++ b/dev-util/its4/Manifest
@@ -1 +1 @@
-DIST its4-1.1.1.tgz 59759 RMD160 7f3fef7b7f5c6cf4f7e203481a44957bcf74e606 SHA1 f95711fad1a10ca127514132db04791a01088d77 SHA256 386ca694c969108863f3e5c0571ea8c5cbdc288dd13e12ba573a592844682df4
+DIST its4-1.1.1.tgz 59759 SHA256 386ca694c969108863f3e5c0571ea8c5cbdc288dd13e12ba573a592844682df4 SHA512 c7bfa71eba114ab3aac586dfa5f30c7a935f06d72b78bae3c3d464f591085cf3419a1d23ab951376bd9c2d7e436711a45c9f5047c3125df5d731b746412be0f6 WHIRLPOOL b734a79abb2eb2a3df330f06852d35aee61c451419fe915fdc0788dbcc9eb51ef282f8bdc9aac2d712fa2bdc21b23a743da9a55dd66fa0a58229036bb1b2e8c8
diff --git a/dev-util/its4/its4-1.1.1-r1.ebuild b/dev-util/its4/its4-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..e000308a5cba
--- /dev/null
+++ b/dev-util/its4/its4-1.1.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="ITS4: Software Security Tool"
+HOMEPAGE="http://www.cigital.com/its4/"
+SRC_URI="${P}.tgz"
+LICENSE="ITS4"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's,iostream.h,iostream,g'\
+ "${S}"/configure || die
+ sed -i \
+ -e 's/$(CC) -o/$(CC) $(OPTIMIZATION) $(EXTRA_FLAGS) -o/' \
+ "${S}"/Makefile.in || die
+}
+
+src_configure() {
+ # WARNING
+ # non-standard configure
+ # do NOT use econf
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/its4 || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" OPTIMIZATION="${CXXFLAGS}" EXTRA_FLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ # WARNING
+ # non-standard, do NOT use einstall or 'make install DESTDIR=...'
+ make install INSTALL_BINDIR="${D}/usr/bin" INSTALL_MANDIR="${D}/usr/share/man" INSTALL_DATADIR="${D}/usr/share/its4" || die "install failed"
+}
diff --git a/dev-util/its4/its4-1.1.1.ebuild b/dev-util/its4/its4-1.1.1.ebuild
index a7e86e1dd3d5..fab10d76369a 100644
--- a/dev-util/its4/its4-1.1.1.ebuild
+++ b/dev-util/its4/its4-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
DESCRIPTION="ITS4: Software Security Tool"
@@ -9,15 +9,9 @@ SLOT="0"
KEYWORDS="x86 ppc"
IUSE=""
DEPEND="sys-devel/gcc"
-RESTRICT="mirror fetch"
#RDEPEND=""
S="${WORKDIR}/${PN}"
-pkg_nofetch() {
- einfo "Please visit ${HOMEPAGE} to download the source, and place it in"
- einfo "${DISTDIR}"
-}
-
src_unpack() {
unpack ${A}
sed -i \