summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-12-31 23:31:32 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-12-31 23:31:32 -0600
commit2b4edbc44e5397a2445d6ff2c4737cdbdd790b99 (patch)
tree504fd2882dc1b5c95c32b3a8265304999b660356 /dev-util/gitlab-runner
parentlxde-base/lxdm: Fix copyright year (diff)
downloadgentoo-2b4edbc44e5397a2445d6ff2c4737cdbdd790b99.tar.gz
gentoo-2b4edbc44e5397a2445d6ff2c4737cdbdd790b99.tar.bz2
gentoo-2b4edbc44e5397a2445d6ff2c4737cdbdd790b99.zip
dev-util/gitlab-runner: add 15.7.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.7.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index a3b8d8fefde4..549d73012f09 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-15.5.1-deps.tar.xz 151906516 BLAKE2B 50dced95fd72259d31d0dd65
DIST gitlab-runner-15.5.1.tar.gz 1327734 BLAKE2B 236d967a5ed18461d64429e078d3e40843e74aca96c23d572d070c13abf7ba3a3c7b4ba6046285d2aed261bdd2d9f5207f23a6b2c7c5cdc95c8cda5e0165f4c3 SHA512 c1ad7144bcea76b9ba20068bccc2b7a96240536cb0bdedcb0566674d05869c38f9052868314c3a58bddb1c6af304030fe0a2d055431d73eaff80ecb2226ea3e4
DIST gitlab-runner-15.6.1-deps.tar.xz 160099188 BLAKE2B 3e8ab94a0af82e3354fd2ff59e313ffd1bbf761bdf9e800c588e54ad5c61b2ac4195d6e33f21d25c6b5c3f82e7385a8f30754b3c38899186a09868aca145b5f6 SHA512 69adf479c70fec6afea252cdaf6c393a7de3069360fcfdbf5c0da57f3ac31f51daf9af2c5d69bd615642c7d9684714aeb720f2e18559d112d30829abaf739a6d
DIST gitlab-runner-15.6.1.tar.bz2 1235815 BLAKE2B 0b689878f49c4373ec9f895f6446d1f896c9f19f67ed306ab2b0ea08de34a9f70ff8547ec730061d9a997073c0b58a85e95e006481c9dab477cf4e5f4aa5f0d2 SHA512 f9580f5a0109ed7406bc33fd9c9936a4023761e790d9b1526a3a1d7037011ebdd8568837451708f0970d75d838f9a9462185542a57091637d1f61874310e8179
+DIST gitlab-runner-15.7.1-deps.tar.xz 160145296 BLAKE2B 523fc6acb99b02f5707a598f16797b40fd833aea3b23d3c1ceecd8187c6cf2401101ccc131d3f2d84ebeb85a8bd74ee5bd2cc930f10ec5f0b2f2ccfde0832287 SHA512 ed1188c8781a958bf718becae240eeb7c24d03c0c83b0cab893a64dc9cc66594b626243f1ac38aade88371b6681f7c04d8e868db48d1d80eb6e8088b62e43816
+DIST gitlab-runner-15.7.1.tar.bz2 1248035 BLAKE2B 361e33ade3b108fd4b5ec042866c167df49acab35c93eb5339b87c1425677a93d0aebbc2fee85ebcb307c0e4096c3a47c3b56bd07537554eacdb4b70f8305d5d SHA512 bcc3b506b08e8c691bcd8a0cf14fa1a2db415b3f7a36e9612cad50994add00d3717456ab74ff024fdd548926b08c832ee7ed289b8972755df58b309c0f1342f9
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.7.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.7.1.ebuild
new file mode 100644
index 000000000000..75970207bdec
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=6d480948
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}