summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-02-25 14:03:04 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-02-25 14:05:30 -0600
commit30de76a9e91d56b5fd3409cfb4382c6b317a767c (patch)
tree1f04c444de01723386d4307775a79ae8783d347c /dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild
parentsci-mathematics/dunshire: PEP517 and python-3.11 support. (diff)
downloadgentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.tar.gz
gentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.tar.bz2
gentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.zip
dev-util/gitlab-runner: add 15.8.3, 15.9.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild')
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild
new file mode 100644
index 000000000000..cfcd4b537a95
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=080abeab
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}