summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/fhist/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/fhist/files')
-rw-r--r--dev-util/fhist/files/1.19-ldflags.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/fhist/files/1.19-ldflags.patch b/dev-util/fhist/files/1.19-ldflags.patch
new file mode 100644
index 000000000000..c0fa0e825a9e
--- /dev/null
+++ b/dev-util/fhist/files/1.19-ldflags.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8aa8408..2c39b28 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -500,8 +500,9 @@ common/sub/expr.$(OBJEXT): common/sub/expr.c common/ac/stdarg.h \
+ $(CC) $(CPPFLAGS) $(CFLAGS) -I. -c common/sub/expr.c
+ mv expr.$(OBJEXT) common/sub/expr.$(OBJEXT)
+
+-common/sub/expr_gram.yacc.c common/sub/expr_gram.yacc.h: \
+- common/sub/expr_gram.y
++common/sub/expr_gram.yacc.c: common/sub/expr_gram.yacc.h
++
++common/sub/expr_gram.yacc.h: common/sub/expr_gram.y
+ $(YACC) -d common/sub/expr_gram.y
+ sed -e 's/[yY][yY]/sub_expr_gram_/g' y.tab.c > \
+ common/sub/expr_gram.yacc.c
+@@ -961,7 +962,7 @@ common/libcommon.a: $(lib_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+@@ -974,7 +975,7 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) \
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+@@ -983,7 +984,7 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir