summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dwdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dwdiff')
-rw-r--r--dev-util/dwdiff/Manifest3
-rw-r--r--dev-util/dwdiff/dwdiff-2.0.10.ebuild41
-rw-r--r--dev-util/dwdiff/dwdiff-2.0.9.ebuild41
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.0.ebuild41
-rw-r--r--dev-util/dwdiff/metadata.xml7
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-util/dwdiff/Manifest b/dev-util/dwdiff/Manifest
new file mode 100644
index 000000000000..205c5ae3a835
--- /dev/null
+++ b/dev-util/dwdiff/Manifest
@@ -0,0 +1,3 @@
+DIST dwdiff-2.0.10.tar.bz2 76285 SHA256 67c4b9fbbbf8ea25335a07c7f4107028649dcd04136a3904778c7a767b843f6f SHA512 670ab12560e3aa98f44a9cd53e87ba8c553807f7864190f9da6db59cc3b152fdb486429b7316e9d0a58d61afc478353924330e984218da52d5017cb6932a6ee7 WHIRLPOOL cad6313439bb885987d593eb6058022937f6370e5ef3151bbdcd341179a033184a16e62f8ad9d606f812d02da90718c513017bba1688d8cb57cbb1bae6c989c3
+DIST dwdiff-2.0.9.tgz 86521 SHA256 c1c9217825ad3fac9936129cc26b73fa5479fb079e5c34522fc7066e74e31ef8 SHA512 73fe43dcc7ba6d3a4e773c7a8b117c359c0470b7b00d7f5bd53781dd046e06b5e02c5adfc7f877bc4ded289a767de3849bacea7cf03883f72046c2d0e7877f1b WHIRLPOOL 9054ef46bfa1f767a2fa64e195afaa7150d2895e99c7bb63cb9380463ce72d5d2e0e9bac336fb677d1a7dfd4c97f98f3e3541a267e1c4ea7096e6f61c4e09b0c
+DIST dwdiff-2.1.0.tar.bz2 79224 SHA256 45308f2f07c08c75c6ebd1eae3e3dcf7f836e5af1467cefc1b4829777c07743a SHA512 63e5ea3ae510c84fa2353da55bbc3cfac3a3753e1cebfb42c387218289a5e19d8e68af663181720a55eca05e49ef075db7d5dafda9dc4d57b9af503553ae9021 WHIRLPOOL 74ceba5cc7c20e0ab6ee09b62f7e8b07a1b8321bbe60ca7c3791c35176ba7137ddf17b1c471ff5ac0586ad0455e67968c71bf00f2de7cb137720b88a85c8f181
diff --git a/dev-util/dwdiff/dwdiff-2.0.10.ebuild b/dev-util/dwdiff/dwdiff-2.0.10.ebuild
new file mode 100644
index 000000000000..c217f2b6370e
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A front-end for the diff program that operates at the word level instead of the line level"
+HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
+SRC_URI="http://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="dev-libs/icu:="
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/dwdiff-2.0.9.ebuild b/dev-util/dwdiff/dwdiff-2.0.9.ebuild
new file mode 100644
index 000000000000..a212df95bcf7
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A front-end for the diff program that operates at the word level instead of the line level"
+HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
+SRC_URI="http://os.ghalkes.nl/dist/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="dev-libs/icu:="
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/dwdiff-2.1.0.ebuild b/dev-util/dwdiff/dwdiff-2.1.0.ebuild
new file mode 100644
index 000000000000..c217f2b6370e
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A front-end for the diff program that operates at the word level instead of the line level"
+HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
+SRC_URI="http://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="dev-libs/icu:="
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/metadata.xml b/dev-util/dwdiff/metadata.xml
new file mode 100644
index 000000000000..8653502db3ff
--- /dev/null
+++ b/dev-util/dwdiff/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>