summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 23:14:58 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 23:35:05 +0200
commitd19af30991a5d184e7cb1820902211db6b96d5db (patch)
tree4dd54f5fbf25d62b402759eb00c35daeebb96e69 /dev-util/duma
parentdev-tcltk/iwidgets: Drop old (EAPI 0) (diff)
downloadgentoo-d19af30991a5d184e7cb1820902211db6b96d5db.tar.gz
gentoo-d19af30991a5d184e7cb1820902211db6b96d5db.tar.bz2
gentoo-d19af30991a5d184e7cb1820902211db6b96d5db.zip
dev-util/duma: Drop old (EAPI 0)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/duma')
-rw-r--r--dev-util/duma/Manifest1
-rw-r--r--dev-util/duma/duma-2.5.13.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-util/duma/Manifest b/dev-util/duma/Manifest
index 4ab63517ca03..365fed56aa9b 100644
--- a/dev-util/duma/Manifest
+++ b/dev-util/duma/Manifest
@@ -1,3 +1,2 @@
DIST duma-2.5.15-GNUmakefile.patch.bz2 4618 BLAKE2B 506127ce1f8f3d01d0443ab1240c585aa734bf3756ae632ccec8ff88f33fc0ffc5113705d5c3c31c14bf52a2cf3c82132669c2c14d24f0c6df17b8e802c8ef40 SHA512 6d83294897a60c6d0ebac388c8f791adc6a199b2c9838497bcfff39502262014c8437a331e08e3526568d3ef755a7dfdc2557771bdae89c58cd5f714eae70df2
-DIST duma_2_5_13.tar.gz 233157 BLAKE2B 233e9dda882ce380af65311adf21052fdf9d023c654aa50a156f79aafba25d1e2db116bffaa9b39232bf0d0c1ace248505ceaf24a1f7a3f24c4d2f34a7bf5ec0 SHA512 da0f46a697f95cbb17d0dbb3135df779ac347fd9e63c1578d2d732300d5288958d02b5a271e84292a8279c1ebc3dc153f896cbeca916cf18aba8e54788671288
DIST duma_2_5_15.tar.gz 240479 BLAKE2B c79f47ba418e22a65a2ad2d4cbff796c2a620ec5f36743d543fe1260e61ec700c648033ac3c91e71be3f3e1129a1c12e9f83a91277244962cfbd494d9588d681 SHA512 0e2abdb08cfbaf9fd0a6be348c831a83ac4ee86d2297dcd1c4d625ddb4b2c1c73eef05e2b895e291d5b8076b1baea559c89d475f30e409210df4ab69b71b6345
diff --git a/dev-util/duma/duma-2.5.13.ebuild b/dev-util/duma/duma-2.5.13.ebuild
deleted file mode 100644
index 8b98e3cc5459..000000000000
--- a/dev-util/duma/duma-2.5.13.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils flag-o-matic multilib toolchain-funcs versionator
-
-MY_P="${PN}_$(replace_all_version_separators '_')"
-
-DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library"
-HOMEPAGE="http://duma.sourceforge.net/"
-
-SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- app-shells/bash"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
- DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
- if [ -n "${DUMA_OPTIONS}" ]; then
- ewarn ""
- elog "Custom build options are ${DUMA_OPTIONS}."
- else
- ewarn ""
- elog "Custom build options are not set!"
- fi
- elog "See the package Makefile for for more options (also installed"
- elog "with package docs as Makefile.duma)."
- ewarn ""
-}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
- sed -i -e "s:(prefix)/lib:(prefix)/$(get_libdir):g" Makefile
- sed -i -e "s:share/doc/duma:share/doc/${P}:g" Makefile
-}
-
-src_compile(){
- replace-flags O? O0
- append-flags -Wall -Wextra -U_FORTIFY_SOURCE
- tc-export AR CC CXX LD RANLIB
-
- use amd64 && export DUMA_ALIGNMENT=16
-
- make CPPFLAGS="${DUMA_OPTIONS}" reconfig || die "make reconfig failed"
- emake CFLAGS="${CFLAGS}" CC=$(tc-getCC) || die "make failed"
-}
-
-src_test() {
- ewarn "Control-C now if you want to disable tests..."
- epause 5
-
- cd "${S}"
- use amd64 && export DUMA_ALIGNMENT=16
- make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
- CC=$(tc-getCC) test || die "make test failed"
-
- elog ""
- ewarn "Check output above to verify all tests have passed. Both"
- ewarn "static and dynamic confidence tests should say PASSED."
- elog ""
-}
-
-src_install(){
- # make install fails nicely here on the first file...
- make DESTDIR="${D}" install || die "make install failed"
- dodoc CHANGELOG TODO
- # All the good comments on duma build options are in the Makefile
- newdoc Makefile Makefile.duma
-
- if use examples; then
- insinto /usr/share/doc/${P}/examples
- doins example[1-6].cpp
- doins example_makes/ex6/Makefile
- fi
-}