summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-11-18 11:01:14 +0100
committerSam James <sam@gentoo.org>2024-12-01 11:25:59 +0000
commitbacb66174d0404b526067d674d088798966ffd92 (patch)
tree710c644d358a848a61333d2bf9fe3d663b0b8329 /dev-util/debugedit
parentsys-devel/dwz: fix hardcoded readelf, pull error-standalone (diff)
downloadgentoo-bacb66174d0404b526067d674d088798966ffd92.tar.gz
gentoo-bacb66174d0404b526067d674d088798966ffd92.tar.bz2
gentoo-bacb66174d0404b526067d674d088798966ffd92.zip
dev-util/debugedit: fix building 5.1 on musl
Grabbed error-standalone instead of forward-porting musl-error.h-fix patch due to debugedit using error() in ways that require proper argument handling: <https://inbox.sourceware.org/debugedit/20241130003201.GG13608@gnu.wildebeest.org/T/#m03918de727ac4fa8be8c7449ec37731710c98121> Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/39409 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/debugedit-5.1-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/debugedit/debugedit-5.1-r2.ebuild b/dev-util/debugedit/debugedit-5.1-r2.ebuild
new file mode 100644
index 000000000000..0af97687c707
--- /dev/null
+++ b/dev-util/debugedit/debugedit-5.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing verify-sig
+
+DESCRIPTION="Create debuginfo and source file distributions"
+HOMEPAGE="https://sourceware.org/debugedit/"
+SRC_URI="
+ https://sourceware.org/ftp/debugedit/${PV}/${P}.tar.xz
+ verify-sig? ( https://sourceware.org/ftp/debugedit/${PV}/${P}.tar.xz.sig )
+"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+#KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/elfutils-0.176-r1:=
+ >=dev-libs/xxhash-0.8:=
+ elibc_musl? ( sys-libs/error-standalone )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-devel/dwz
+"
+BDEPEND="
+ sys-apps/help2man
+ virtual/pkgconfig
+ verify-sig? (
+ sec-keys/openpgp-keys-debugedit
+ )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/debugedit.gpg
+
+src_prepare() {
+ default
+
+ # bashism, https://sourceware.org/bugzilla/show_bug.cgi?id=32321
+ sed -i -e '/test/s:==:=:' tests/debugedit.at || die
+}
+
+src_configure() {
+ local myconf=(
+ # avoid BDEP on dwz
+ DWZ=dwz
+ ac_cv_dwz_j=yes
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake -Onone check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}