summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-11 11:42:33 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-11 11:42:33 -0700
commit71821def8bdcd61a1e0f317085d5d7c42009b642 (patch)
tree5ac2611ec9986d546edb2b42a1aad08f61987bb0 /dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
parentdev-python/hatchling: Update HOMEPAGE (diff)
downloadgentoo-71821def8bdcd61a1e0f317085d5d7c42009b642.tar.gz
gentoo-71821def8bdcd61a1e0f317085d5d7c42009b642.tar.bz2
gentoo-71821def8bdcd61a1e0f317085d5d7c42009b642.zip
dev-util/chroot-wrapper: Version bump (0.9.9), remove old
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild')
-rw-r--r--dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild b/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
new file mode 100644
index 000000000000..68276acbf49a
--- /dev/null
+++ b/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Wrapper for chroot to set up some bind mounts, namespaces, and control groups"
+HOMEPAGE="https://github.com/chutz/chroot-wrapper"
+SRC_URI="https://github.com/chutz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ sys-apps/util-linux
+ sys-apps/coreutils
+"
+
+CONFIG_CHECK="
+ ~TMPFS
+ ~IPC_NS
+ ~UTS_NS
+"
+
+src_install() {
+ newsbin src/chroot-wrapper chr
+ insinto /etc/chroot-wrapper
+ doins config.bash
+}