summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-06-01 11:51:17 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-06-01 15:57:31 -0700
commitfa4262b9f666b2db85493d828935e421fa08efa2 (patch)
tree8165ce6c65198a88b247a98da84c8bf9f70f5e1f /dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild
parentdev-util/buildbot-grid-view: Version bump, clean vulnerable versions (diff)
downloadgentoo-fa4262b9f666b2db85493d828935e421fa08efa2.tar.gz
gentoo-fa4262b9f666b2db85493d828935e421fa08efa2.tar.bz2
gentoo-fa4262b9f666b2db85493d828935e421fa08efa2.zip
dev-util/buildbot-wsgi-dashboards: Version bump, clean vulnerable
gentoo-bug: https://bugs.gentoo.org/show_bug.cgi?id=711702 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild
new file mode 100644
index 000000000000..f124a0ef5c54
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"