summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-07-15 17:41:26 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-17 18:09:07 +0100
commitf7d7dd4261989165a26bb65d4a8ff153b2053757 (patch)
tree0c86e8d749a36325b491195d2a8e5f40d1441624 /dev-util/bitrise
parentapp-metrics/node_exporter: Remove old (diff)
downloadgentoo-f7d7dd4261989165a26bb65d4a8ff153b2053757.tar.gz
gentoo-f7d7dd4261989165a26bb65d4a8ff153b2053757.tar.bz2
gentoo-f7d7dd4261989165a26bb65d4a8ff153b2053757.zip
dev-util/bitrise: bump version 1.19.0
Bug: https://bugs.gentoo.org/657710 Closes: https://bugs.gentoo.org/657710 Closes: https://github.com/gentoo/gentoo/pull/9237
Diffstat (limited to 'dev-util/bitrise')
-rw-r--r--dev-util/bitrise/Manifest1
-rw-r--r--dev-util/bitrise/bitrise-1.19.0.ebuild45
-rw-r--r--dev-util/bitrise/metadata.xml2
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-util/bitrise/Manifest b/dev-util/bitrise/Manifest
index 63b8867a3224..3903da5834c9 100644
--- a/dev-util/bitrise/Manifest
+++ b/dev-util/bitrise/Manifest
@@ -1 +1,2 @@
DIST bitrise-1.16.1.tar.gz 3986520 BLAKE2B 2a38eb72abc2aee69b9494abe03434014531a5081e8d71e7883418d686dffd1de8d61b2dda8761a1d074392a4f84699a4cff36be4f6be8abf52ba705434b8283 SHA512 37d87a27f2d3c17df7c61eebb8ab50887c7f723901125af08a5833bd053c5706cf1a2d3310fa30a6ade3bec8292b30bc4ddfb3143ece8129c606fcbe5103ddd6
+DIST bitrise-1.19.0.tar.gz 4223634 BLAKE2B cb0822af15c1214d785f002617cd5c184e50a85c289d7ef5fe4fb429009495db26935aea9b9fbdb43514221d233a10347b52d01c0f839bb981da8437d61f79a1 SHA512 ef0ca59a907bf85ceadd2bccb7859e6b40146fd4983d51c84f82ba3ac36b47eeef41cbd342cfcbe516ed2ee678e66a4e07ef451cc36a7b6977fa6def9ac2a1e4
diff --git a/dev-util/bitrise/bitrise-1.19.0.ebuild b/dev-util/bitrise/bitrise-1.19.0.ebuild
new file mode 100644
index 000000000000..2cb6e23d9810
--- /dev/null
+++ b/dev-util/bitrise/bitrise-1.19.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Run your Bitrise.io automations on any Mac or Linux machine"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-util/envman-1.2.0
+>=dev-util/stepman-0.10.0"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/bitrise" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/bitrise || die "Couldn't compile bitrise"
+}
+
+src_test() {
+ export PULL_REQUEST_ID=""
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/bitrise"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/bitrise
+ dodoc README.md
+ use doc && dodoc -r _docs
+}
diff --git a/dev-util/bitrise/metadata.xml b/dev-util/bitrise/metadata.xml
index d00260bae974..c4961be108e0 100644
--- a/dev-util/bitrise/metadata.xml
+++ b/dev-util/bitrise/metadata.xml
@@ -14,6 +14,6 @@
<bugs-to>https://github.com/bitrise-io/bitrise/issues</bugs-to>
<changelog>https://github.com/bitrise-io/bitrise/blob/master/CHANGELOG.md</changelog>
<doc>https://github.com/bitrise-io/bitrise/blob/master/README.md</doc>
- <remote-id type="github">bitriseio/bitrise</remote-id>
+ <remote-id type="github">bitrise-io/bitrise</remote-id>
</upstream>
</pkgmetadata>