summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-03 09:23:09 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-03 10:12:00 +0100
commit9990fcfe98daa6ae75b6afeac3108756d266a788 (patch)
tree72ced8ba5019137a118b6a60e10b0738aa5b893f /dev-ruby
parentdev-ruby/redcloth: drop 4.3.2-r5 (diff)
downloadgentoo-9990fcfe98daa6ae75b6afeac3108756d266a788.tar.gz
gentoo-9990fcfe98daa6ae75b6afeac3108756d266a788.tar.bz2
gentoo-9990fcfe98daa6ae75b6afeac3108756d266a788.zip
dev-ruby/rbst: add python3_12, ruby33, fix tests
Closes: https://bugs.gentoo.org/835404 Closes: https://bugs.gentoo.org/929523 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rbst/rbst-0.6.5-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-ruby/rbst/rbst-0.6.5-r1.ebuild b/dev-ruby/rbst/rbst-0.6.5-r1.ebuild
index 8b44aba69e0c..4033cecb817c 100644
--- a/dev-ruby/rbst/rbst-0.6.5-r1.ebuild
+++ b/dev-ruby/rbst/rbst-0.6.5-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-USE_RUBY="ruby30 ruby31 ruby32"
+PYTHON_COMPAT=( python3_{10..12} )
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_NAME="RbST"
RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"
@@ -34,7 +34,7 @@ DEPEND="
ruby_add_bdepend "
test? (
>=dev-ruby/minitest-5.14.0:5
- >=dev-ruby/mocha-1.1.0:1.0
+ dev-ruby/mocha:2
)
"
@@ -57,4 +57,12 @@ all_ruby_prepare() {
# force our python version
sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
python_fix_shebang lib/rst2parts
+
+ # Update test file for latest docutils output
+ sed -e '/footnote/ s/id1/footnote-1/' \
+ -e '/backref/ s/id3/footnote-reference-1/' \
+ -e '/backref/ s/id4/citation-reference-1/' \
+ -e '/footnote-reference/ s/id3/footnote-reference-1/' \
+ -e '/citation-reference/ s/id4/citation-reference-1/' \
+ -i test/files/test.html || die
}