summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-20 10:43:53 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-20 10:44:45 +0200
commita2b03a6034220de7aab85dfe9bc72ffa9d79a8d6 (patch)
tree6f2f6ae0d588414ae975945fa838cd522a70270f /dev-ruby/shoulda
parentgnome-extra/gnome-shell-extension-weather-in-the-clock: drop 20221024 (diff)
downloadgentoo-a2b03a6034220de7aab85dfe9bc72ffa9d79a8d6.tar.gz
gentoo-a2b03a6034220de7aab85dfe9bc72ffa9d79a8d6.tar.bz2
gentoo-a2b03a6034220de7aab85dfe9bc72ffa9d79a8d6.zip
dev-ruby/shoulda: fix shoulda-context dependency
Match the gemspec and lock to slot 0 for shoulda-context. Closes: https://bugs.gentoo.org/910577 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/shoulda-3.6.0-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-3.6.0-r3.ebuild b/dev-ruby/shoulda/shoulda-3.6.0-r3.ebuild
new file mode 100644
index 000000000000..dc60ed190d3a
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-3.6.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1:0
+ dev-ruby/shoulda-matchers:3"
+
+all_ruby_prepare() {
+ sed -e '/executables/,/^ end/d ; /test_files/d; s/git ls-files/find * -print/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}