summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-15 08:22:22 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-15 10:09:18 +0200
commitffadafddb75913e6339a19bd2ad967b0c0b6f857 (patch)
treec8a2c03290703106318657c83a2531a22b1cd181 /dev-ruby/rr/rr-3.1.0.ebuild
parentapp-office/unoconv: cleanup (diff)
downloadgentoo-ffadafddb75913e6339a19bd2ad967b0c0b6f857.tar.gz
gentoo-ffadafddb75913e6339a19bd2ad967b0c0b6f857.tar.bz2
gentoo-ffadafddb75913e6339a19bd2ad967b0c0b6f857.zip
dev-ruby/rr: add 3.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rr/rr-3.1.0.ebuild')
-rw-r--r--dev-ruby/rr/rr-3.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rr/rr-3.1.0.ebuild b/dev-ruby/rr/rr-3.1.0.ebuild
new file mode 100644
index 000000000000..3c2796a72e4e
--- /dev/null
+++ b/dev-ruby/rr/rr-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC=rr.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="A double framework featuring a selection of double techniques and a terse syntax"
+HOMEPAGE="https://rr.github.io/rr"
+SRC_URI="https://github.com/rr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest
+ dev-ruby/diff-lcs
+ dev-ruby/test-unit-rr )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}