summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-28 06:37:52 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-28 06:38:02 +0200
commit75bae68dd8e2993f8830374b08310146b69dbd52 (patch)
treeb663c12cb201dc718cec98d7d70dbec7c1e426bf /dev-ruby/rjb
parentdev-ruby/rbs: add 3.2.2 (diff)
downloadgentoo-75bae68dd8e2993f8830374b08310146b69dbd52.tar.gz
gentoo-75bae68dd8e2993f8830374b08310146b69dbd52.tar.bz2
gentoo-75bae68dd8e2993f8830374b08310146b69dbd52.zip
dev-ruby/rjb: add 1.6.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/Manifest1
-rw-r--r--dev-ruby/rjb/rjb-1.6.8.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
index 28ab61da4b82..b522ee00306d 100644
--- a/dev-ruby/rjb/Manifest
+++ b/dev-ruby/rjb/Manifest
@@ -1 +1,2 @@
DIST rjb-1.6.7.gem 74752 BLAKE2B 835bc45b4568599e030033d9cff4d1df2da2cffd63ad594a437eeae7974d5e6f1bea490631c79f0990697f006e0006aab923134860aaf57312b153f750bda62b SHA512 ae5980621900d2605372f1cb3783d213e19da7bf1a7b2834dbdb99895476ecf2dad0ee474140e2747bbd477a5ab6d4be94cc9bf4fd0b8f0109ded94d7621bb7e
+DIST rjb-1.6.8.gem 74752 BLAKE2B 795e80879819b7a1b1834d901b9473f5a2ee39b1b68e264ef6ce7931bf312fd0a66e898bc2d4a86f2decca87fb1f6568709a6230b8ffbf3a2202d5951f97ca3d SHA512 f5c3a17ea494c484d5a3e929de370e697c971e9e976ce8a3b38c3fe2a5c074503e5edc91eb782d4e3f0ef0fd51d3a6ba9b147dff1c69e1e895c45f0fb84f478e
diff --git a/dev-ruby/rjb/rjb-1.6.8.ebuild b/dev-ruby/rjb/rjb-1.6.8.ebuild
new file mode 100644
index 000000000000..49bcfd18a275
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.6.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit java-pkg-2 ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="https://github.com/arton/rjb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.8
+ hardened? ( sys-apps/paxctl )"
+RDEPEND=">=virtual/jre-1.8:*"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+
+ # Fix build on openjdk-11
+ sed -i -e 's#javah -classpath ../data/rjb jp.co.infoseek.hp.arton.rjb.RBridge#javac -h . -classpath ../data/rjb RBridge.java#g' ext/extconf.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ if use examples; then
+ dodoc -r samples
+ fi
+}
+
+each_ruby_test() {
+ if use hardened; then
+ paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
+ if [ $? = 0 ]; then
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ else
+ ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
+ fi
+ else
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ fi
+}