summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-15 07:24:13 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-15 07:24:13 +0200
commita6f5fe87b6c528b5e75214955326267ed9d1d226 (patch)
treeaac0fce1954ebdc92e19f5f6f9318af170828fa5 /dev-ruby/reline/reline-0.5.7.ebuild
parentdev-vcs/fossil: Fix incorrect checksum and tests (diff)
downloadgentoo-a6f5fe87b6c528b5e75214955326267ed9d1d226.tar.gz
gentoo-a6f5fe87b6c528b5e75214955326267ed9d1d226.tar.bz2
gentoo-a6f5fe87b6c528b5e75214955326267ed9d1d226.zip
dev-ruby/reline: add 0.5.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/reline/reline-0.5.7.ebuild')
-rw-r--r--dev-ruby/reline/reline-0.5.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/reline/reline-0.5.7.ebuild b/dev-ruby/reline/reline-0.5.7.ebuild
new file mode 100644
index 000000000000..a779c43093ce
--- /dev/null
+++ b/dev-ruby/reline/reline-0.5.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md doc/reline/face.md"
+RUBY_FAKEGEM_GEMSPEC="reline.gemspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Alternative readline implementation in pure Ruby"
+HOMEPAGE="https://github.com/ruby/reline"
+SRC_URI="https://github.com/ruby/reline/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend ">=dev-ruby/io-console-0.5.0:0"
+
+all_ruby_prepare() {
+ sed -e "s:_relative ':'./:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test/reline -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}