summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-04 07:43:42 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-05 07:25:52 +0100
commitc1cc04834b0c6988a46d44228c3095b4a58c85ec (patch)
tree83588ec8cb9cd2c5ef0eda08e4c3e9dc0fd53b4c /dev-ruby/rbpdf
parentdev-ruby/netrc: cleanup (diff)
downloadgentoo-c1cc04834b0c6988a46d44228c3095b4a58c85ec.tar.gz
gentoo-c1cc04834b0c6988a46d44228c3095b4a58c85ec.tar.bz2
gentoo-c1cc04834b0c6988a46d44228c3095b4a58c85ec.zip
dev-ruby/rbpdf: add 1.18.7
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/rbpdf')
-rw-r--r--dev-ruby/rbpdf/Manifest1
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.18.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rbpdf/Manifest b/dev-ruby/rbpdf/Manifest
index a1181c85dec8..4d116efd1a3d 100644
--- a/dev-ruby/rbpdf/Manifest
+++ b/dev-ruby/rbpdf/Manifest
@@ -1 +1,2 @@
DIST rbpdf-1.18.6.gem 5764096 SHA256 d5d1e30ad1465bea5b3c1809cf2789c6795dafbfba6c2cab40c628989229b650 SHA512 a2c30082211d4b170c7cfea72f839541364d7e6b9da29b33a489a5900f63f2cc6ccb85c099ba2f090eec96c79c50026195f9a4a03c04274eea691188271b839b WHIRLPOOL 100c7ba0c7e21edf669d5a82ea8172f886dc9b804b4ecd93ae43b0baa25e3d2f15ce80f91cefa6b6400a0c829830780a3d7a4c7d9473895d25f2ba3720916107
+DIST rbpdf-1.18.7.gem 5764608 SHA256 fd8f281229626c8d92104acdd9eafb1551b8cec8811bcb3253bdcb25b3eb8b6c SHA512 dce679ea941ec23c4f3964ac016cd72ee2f8aaffcde63a1eecbd7fadea797f97f1dd6f703bf1e9e809a58d5694033ea78b01de4082bfb6679f6234c1c8a9ee11 WHIRLPOOL 29956cb03d9be350967af2d18de83cdd4cec5692e4ed8081480080e716b269fd1206fa492e561610c89235ab17a3efa963f42ad0700fae967ffc5631e776ed5f
diff --git a/dev-ruby/rbpdf/rbpdf-1.18.7.ebuild b/dev-ruby/rbpdf/rbpdf-1.18.7.ebuild
new file mode 100644
index 000000000000..1ec1872f7d64
--- /dev/null
+++ b/dev-ruby/rbpdf/rbpdf-1.18.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 support waiting on dev-ruby/action{pack,view}.
+USE_RUBY="ruby20 ruby21"
+
+# Avoid the complexity of the "rake" recipe and run the tests manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails RBPDF plugin"
+HOMEPAGE="https://github.com/naitoh/rbpdf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Try to pick the right version of minitest. In order to run, the test
+# suite needs matching versions of actionview and activesupport. The
+# easiest way to do this is to pull them in simultaneously with
+# actionpack.
+ruby_add_bdepend "test? ( || (
+ ( dev-ruby/actionpack:3.2 dev-ruby/minitest:0 )
+ ( dev-ruby/actionpack:4.0 dev-ruby/minitest:0 )
+ ( dev-ruby/actionpack:4.1 dev-ruby/minitest:5 )
+ ( dev-ruby/actionpack:4.2 dev-ruby/minitest:5 )
+) )"
+
+ruby_add_rdepend ">=dev-ruby/htmlentities-4.3.1"
+
+all_ruby_prepare() {
+ default
+
+ # This test is enabled automagically in the presence of rmagick, and
+ # then fails.
+ rm -f test/rbpdf_image_rmagick_test.rb \
+ || die "failed to remove rmagick tests"
+
+ # Loosen very restrictive htmlentities dependency
+ sed -i -e '/htmlentities/ s/=/>=/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ local cmd='gem "minitest"'
+ cmd+=' and '
+ cmd+='require "minitest/autorun"'
+ cmd+=' and '
+ cmd+='Dir["test/**/*_test.rb"].each{|f| require f}'
+ ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
+}