summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rake-compiler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/Manifest2
-rw-r--r--dev-ruby/rake-compiler/metadata.xml8
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild59
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.9.5.ebuild62
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-ruby/rake-compiler/Manifest b/dev-ruby/rake-compiler/Manifest
new file mode 100644
index 000000000000..59f56e43f343
--- /dev/null
+++ b/dev-ruby/rake-compiler/Manifest
@@ -0,0 +1,2 @@
+DIST rake-compiler-0.9.2.tar.gz 30778 SHA256 72ced9a0ca9a034506de279e888fdec63d542d788ee1d2e7910f1bfd71c82dd3 SHA512 883157bf44540cd021bec22a84e907922756f74a61e84c62e51eed752da01d217a03aebd88582fbe779210116e7ab1a36023707fbdae445b5ac4499c7de9b8eb WHIRLPOOL 79b21689e08ac21005243a2f18bde0941c3a86bdd3bf36bf557d3c706cb64fcb379f2d3fd06c93d3c07f10e8c1e47c75933ba783cc23b57137d9fce6c3e7de78
+DIST rake-compiler-0.9.5.tar.gz 31727 SHA256 c3ddd7cb4003d4116aef89313d4bf6ad338ea1c6e0552825c78a6109e80e931e SHA512 ce40ac3d57458e7369d3bf2c7cc033911775d6afee85867a96ea95f564cf9b294d4f1030530f547f27a0834ba4b33121abeb33a2f6b7a2d02346311ed11759b5 WHIRLPOOL df94ce4ce7e3842f4585f66c25422f59c03cf851cc596da9d35aac34cf6d79c615245ffe642116cd655454a8192b3985ca9d4db442d33894155191ab1f095038
diff --git a/dev-ruby/rake-compiler/metadata.xml b/dev-ruby/rake-compiler/metadata.xml
new file mode 100644
index 000000000000..861a496b3d04
--- /dev/null
+++ b/dev-ruby/rake-compiler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">luislavena/rake-compiler</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild
new file mode 100644
index 000000000000..5b57ad0b57a3
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="luislavena-${PN}-*"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+USE_RUBY="ruby19 ruby20" ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Skip cucumber for jruby (not supported) and ruby20 (not ready yet)
+ # Skip rspec as well for ruby21 to allow bootstrapping rspec for ruby21
+ case ${RUBY} in
+ *ruby19)
+ ruby-ng_rspec
+ ruby-ng_cucumber
+ ;;
+ *ruby21)
+ ;;
+ *)
+ ruby-ng_rspec
+ ;;
+ esac
+}
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.9.5.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.9.5.ebuild
new file mode 100644
index 000000000000..cde972a37ae3
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.9.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="https://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luislavena/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
+
+USE_RUBY="ruby19 ruby20" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ # Make sure the right rspec version is used in cucumber.
+ sed -i -e "1igem 'rspec', '~>2.0'" features/support/env.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Remove this task so that it won't load on Ruby 1.9
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Skip cucumber for ruby21 (not ready yet)
+ case ${RUBY} in
+ *ruby19|*ruby20)
+ ruby-ng_rspec
+ ruby-ng_cucumber
+ ;;
+ *)
+ ruby-ng_rspec
+ ;;
+ esac
+}