summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-03-20 10:45:03 -0400
committerSam James <sam@gentoo.org>2023-03-22 01:18:28 +0000
commit247d7a3d079139d72a004a0b1a64350a2ebc4853 (patch)
tree95d55b10c97fdd07947b73461fb3a87bb8175f89 /dev-ruby/llhttp-ffi
parentapp-editors/gvim: version bump to v9.0.1403. (diff)
downloadgentoo-247d7a3d079139d72a004a0b1a64350a2ebc4853.tar.gz
gentoo-247d7a3d079139d72a004a0b1a64350a2ebc4853.tar.bz2
gentoo-247d7a3d079139d72a004a0b1a64350a2ebc4853.zip
dev-ruby/llhttp-ffi: add explicit rspec test dep
Needs to be a test dep, but should NOT have RUBY_FAKEGEM_RECIPE_TEST set as it needs to be called via rake. Closes: https://bugs.gentoo.org/878053 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/30261 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/llhttp-ffi')
-rw-r--r--dev-ruby/llhttp-ffi/llhttp-ffi-0.4.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/llhttp-ffi/llhttp-ffi-0.4.0.ebuild b/dev-ruby/llhttp-ffi/llhttp-ffi-0.4.0.ebuild
index 2f1dcb8c942b..634c3b609568 100644
--- a/dev-ruby/llhttp-ffi/llhttp-ffi-0.4.0.ebuild
+++ b/dev-ruby/llhttp-ffi/llhttp-ffi-0.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,10 @@ RUBY_S="llhttp-${MY_PV}/ffi"
ruby_add_rdepend "=dev-ruby/ffi-compiler-1*"
-ruby_add_bdepend "test? ( dev-ruby/async-io )"
+ruby_add_bdepend "test? (
+ dev-ruby/async-io
+ dev-ruby/rspec:3
+)"
all_ruby_prepare() {
sed -i -e 's/gem "rake-compiler"//g' "Gemfile" || die