summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-27 08:41:08 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-27 08:44:50 +0200
commitde19240122ad9661915fcf3ca54c02b539e0c2d1 (patch)
tree51b6bec665e67383b599f1796edb798de27a610c /dev-ruby/http-parser
parentdev-ruby/instance_storage: drop 1.0.0-r1, 2.0.0 (diff)
downloadgentoo-de19240122ad9661915fcf3ca54c02b539e0c2d1.tar.gz
gentoo-de19240122ad9661915fcf3ca54c02b539e0c2d1.tar.bz2
gentoo-de19240122ad9661915fcf3ca54c02b539e0c2d1.zip
dev-ruby/http-parser: enable ruby32, add missing compile dep
Closes: https://bugs.gentoo.org/912259 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http-parser')
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild b/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild
index 8b85b5fe20db..ffd1acd4c706 100644
--- a/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild
+++ b/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -21,7 +21,7 @@ IUSE=""
DEPEND+=" >=net-libs/http-parser-2.8.1"
RDEPEND+=" >=net-libs/http-parser-2.8.1"
-ruby_add_bdepend "dev-ruby/ffi-compiler"
+ruby_add_bdepend "dev-ruby/ffi-compiler dev-ruby/rake"
each_ruby_compile() {
${RUBY} -C ext -S rake || die